SMSSP3_OM07_MPGD.cover

Manuale di Microsoft Systems Management Server 2003 Service Pack 3 Management Pack per Operations Manager 2007

Microsoft Corporation

Pubblicato: maggio 2007

Commenti e suggerimenti

Inviare commenti e suggerimenti relativi al presente documento all'indirizzo smsdocs@microsoft.com includendo il titolo del manuale di Management Pack.


SMSSP3_OM2007_MPGuide.copy

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Unless otherwise noted, the companies, organizations, products, domain names, e-mail addresses, logos, people, places, and events depicted in examples herein are fictitious. No association with any real company, organization, product, domain name, e-mail address, logo, person, place, or event is intended or should be inferred. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Microsoft Corporation.

Microsoft may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Microsoft, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

© 2007 Microsoft Corporation. All rights reserved.

Microsoft, MS-DOS, Windows, Windows Server, and Windows Vista are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

All other trademarks are property of their respective owners.


Microsoft System Management Server 2003 Management Pack for Operations Manager 2007

Microsoft® System Management Server 2003 Management Pack for Operations Manager 2007 è un pacchetto di gestione che offre funzionalità nuove e migliorate per il monitoraggio di SMS 2003.

Risorse del Management Pack

Per ulteriori informazioni sulle funzionalità e le risorse disponibili, vedere gli argomenti seguenti.

Panoramica di System Management Server 2003 Management Pack

  • Scenari di monitoraggio del Management Pack
  • Distribuzione di SMS 2003 Management Pack
  • Esecuzione di attività operative per SMS 2003 Management Pack
  • Risoluzione dei problemi relativi a SMS 2003 Management Pack
  • Materiale di riferimento per Microsoft System Management Server 2003 Management Pack


Panoramica di System Management Server 2003 Management Pack
Vedere anche

In questo manuale vengono fornite informazioni tecniche e di distribuzione relative a SMS 2003 Management Pack che consentono di pianificare la distribuzione di Management Pack, conoscere le funzionalità disponibili e utilizzarle in modo ottimale all'interno dell'organizzazione IT.

System Center Operations Manager 2007 Management Pack per SMS offre funzionalità migliorate per il monitoraggio di SMS 2003, inclusi:

  • Monitoraggio di avvio e interruzione di tutti i servizi SMS 2003, inclusi servizi dipendenti critici quali WMI (Strumentazione gestione Windows), IIS (Internet Information Services), BITS (Servizio trasferimento intelligente in background) e Microsoft SQL Server™.
  • Invio di avvisi all'amministratore di SMS in caso di messaggi di stato SMS critici.
  • Monitoraggio dei backlog di record dei dati di individuazione, inventario software, inventario hardware, messaggi di stato e controllo software su server del sito primario e punti di gestione.
  • Monitoraggio dell'utilizzo delle risorse di sistema.
  • Monitoraggio delle frequenze di elaborazione.
  • Monitoraggio delle tendenze delle prestazioni di numerosi contatori delle prestazioni di SMS mediante viste e report.
  • Knowledge Base predefinita per tutti gli avvisi e le regole di elaborazione.
  • Rilevamento di tutti i computer e gruppi di computer SMS 2003.
  • Viste.
  • Report per la visualizzazione di prestazioni, disponibilità e configurazione dei punti di gestione e dei gruppi di server SMS 2003. Sono inclusi report collegati che offrono funzionalità di report avanzate per le tendenze delle prestazioni, della configurazione e della disponibilità di Systems Center Operations Manager 2007.
  • Monitoraggio di Device Management Feature Pack.
  • Attività per l'esecuzione delle applicazioni della console di amministrazione SMS.
  • Vista dello stato con informazioni sull'integrità di tutti i ruoli del server SMS e del client avanzato di SMS.
  • Processo di individuazione dei servizi per la raccolta di informazioni importanti sul server e sul client SMS.
  • Avvisi di eliminazione dei servizi non disponibile derivanti dall'esecuzione del servizio SMS Site Backup.
  • Diagramma della topologia della gerarchia del sito SMS (necessario SMS 2003 Service Pack 3).
  • Avvisi configurabili di SMS 2003 Service Pack 3 (SP3) relativi alla mancata esecuzione dei programmi distribuiti attraverso le proprietà del programma SMS.

Per ulteriori informazioni sulle funzionalità e sugli scenari di monitoraggio, vedere Scenari di monitoraggio del Management Pack. SMS 2003 Management Pack non è stato progettato per offrire le funzionalità seguenti:

  • Monitoraggio di SMS 1.2, SMS 2.0, SMS 2003 SP2.
  • Monitoraggio di ambienti SMS misti, ovvero ambienti in cui vengono eseguite contemporaneamente installazioni di SMS 1.2, SMS 2.0 e SMS 2003.
  • Monitoraggio limitato dei computer del solo client SMS che eseguono il client avanzato di SMS.
  • Soluzione di monitoraggio pronta all'utilizzo per la gestione di qualsiasi installazione di SMS 2003 senza la necessità di modifiche. Le soglie delle regole sono diverse per ogni installazione di SMS 2003 e i clienti devono personalizzare le regole personalmente.

In questa sezione

Novità di questo aggiornamento

Nozioni e competenze consigliate

Configurazione di SMS supportata

Vedere anche

Concetti

Scenari di monitoraggio del Management Pack
Distribuzione di SMS 2003 Management Pack

Altre risorse

Esecuzione di attività operative per SMS 2003 Management Pack
Risoluzione dei problemi relativi a SMS 2003 Management Pack
Materiale di riferimento per Microsoft System Management Server 2003 Management Pack


Novità di questo aggiornamento

Systems Management Server 2003 Management Pack for Operations Manager 2007 include la modalità manutenzione. Questa modalità consente di eliminare gli avvisi di Operations Manager inviati dai computer client mentre SMS è in esecuzione nel computer client.

Aggiornare la modalità manutenzione per SMS 2003

Quando si distribuiscono programmi nei computer tramite System Management Server 2003, è spesso necessario disattivare temporaneamente gli avvisi di Operations Manager basati su regole generati dal computer di destinazione. La distribuzione di aggiornamenti rapidi e patch di protezione su server può ad esempio richiedere la chiusura di thread e servizi. Se i thread o i servizi di tali server sono monitorati da un Management Pack, è possibile che vengano generati numerosi avvisi di Operations Manager che potrebbero sovraccaricare il server Operations Manager.

La casella di controllo Disable MOM alerts while this program runs consente di sospendere la visualizzazione degli avvisi di Operations Manager fino al termine della distribuzione del software. L'amministratore di SMS può selezionare questa casella di controllo nelle proprietà di programma del pacchetto SMS. L'impostazione di questa opzione implica l'eliminazione degli avvisi di Operations Manager per tutti i Management Pack destinati al computer client mentre tale computer esegue tale programma.

Se questa opzione è selezionata, quando l'annuncio viene eseguito nel computer di destinazione l'agente Microsoft Operations Manager entrerà in modalità manutenzione. L'agente SMS fornisce inoltre un'impostazione di timeout per l'agente Microsoft Operations Manager. Dopo l'esecuzione dell'annuncio nel computer di destinazione, l'agente del client di SMS riprenderà il monitoraggio del computer tramite l'agente Microsoft Operations Manager. Eventuali eventi che generano avvisi verranno segnalati normalmente da questo momento in poi.

Se la distribuzione del software non viene eseguita correttamente nel computer di destinazione, verranno eseguite le operazioni seguenti:

  • Se la distribuzione restituisce un codice di errore, l'agente SMS interromperà la modalità manutenzione per l'agente Microsoft Operations Manager come se la distribuzione fosse stata eseguita correttamente.
  • Se si verifica un errore inatteso e l'agente SMS non riceve un codice di errore entro un timeout predefinito, l'agente Microsoft Operations Manager interromperà la modalità manutenzione.

Attivare la modalità manutenzione per un programma SMS 2003

Per attivare la modalità manutenzione in computer client durante l'esecuzione di programmi SMS 2003, attenersi alla procedura seguente.

Per attivare la modalità manutenzione per un programma SMS 2003

  1. Nella console Systems Management Server passare a Systems Management Server / Site Database - <nome server sito> / Packages.

  2. Nel riquadro dei dettagli fare clic con il pulsante destro su Program e quindi scegliere Properties.

  3. Nella finestra di dialogo Program Properties fare clic sulla scheda MOM.

  4. Selezionare Disable MOM alerts while this program runs e quindi fare clic su OK.

Se viene attivata la modalità manutenzione per il programma SMS 2003, il computer client passerà a tale modalità quando il pacchetto di SMS 2003 verrà distribuito ed eseguito.

Nota
Il timeout della modalità manutenzione viene impostato nella scheda Requirements della finestra di dialogo Program Properties dopo avere selezionato la proprietà Maximum allowed runtime.

Topologia del sito SMS 2003

I diagrammi gerarchici di SMS 2003 disponibili in Microsoft Operations Manager (MOM) 2005 sono stati sostituiti con una gerarchia del sito SMS 2003. La visualizzazione gerarchica include ora nella topologia anche i ruoli del server.

Script di configurazione rimossi

Poiché è consigliabile utilizzare SMS 2003 SP2 o versioni successive, gli script di configurazione sono stati rimossi.

Report per SMS 2003

SMS 2003 include nuovi report che utilizzano i contatori delle prestazioni per i ruoli del sistema del sito e per i contatori di elaborazione degli oggetti, ad esempio i contatori relativi ai record dei dati di individuazione. Per ulteriori informazioni sui nuovi report, vedere Report per SMS 2003.

Vedere anche

Concetti

Report per SMS 2003
Script per SMS 2003


Nozioni e competenze consigliate

Per distribuire e utilizzare SMS 2003 Management Pack, è consigliabile disporre delle nozioni e competenze seguenti:

  • Nozioni di utilizzo delle funzionalità di monitoraggio di Operations Manager 2007. Per ulteriori informazioni su Operations Manager 2007, vedere la pagina Web Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).
  • Nozioni dell'architettura di progettazione di Operations Manager 2007 e dell'architettura di progettazione distribuita nell'organizzazione.
  • Conoscenza del processo consigliato per la distribuzione dei Management Pack come descritto nella guida alla distribuzione di System Center Operations Manager 2007.
  • Nozioni sui concetti e sulla terminologia di SMS. Per ulteriori informazioni su SMS 2003, vedere la pagina Web relativa alla documentazione di SMS 2003 (http://go.microsoft.com/fwlink/?linkid=9502).

Vedere anche

Concetti

Scenari di monitoraggio del Management Pack
Distribuzione di SMS 2003 Management Pack

Altre risorse

Esecuzione di attività operative per SMS 2003 Management Pack


Configurazione di SMS supportata

I requisiti per SMS 2003 e Systems Center Operations Manager 2007 sono descritti nelle rispettive guide per la distribuzione. SMS 2003 Management Pack consente di monitorare SMS 2003. È consigliabile utilizzare SMS 2003 SP2 o versione successiva. L'esecuzione di SMS 2003 SP1 richiede l'esecuzione di uno script con contrassegno.

L'attivazione della modalità manutenzione durante la distribuzione del software e il mapping della topologia con Operations Manager 2007 richiedono SMS 2003 SP3 o versione successiva.

Questo SMS 2003 Management Pack non consente di monitorare SMS 1.2, SMS 2.0 o Gestione configurazione 2007.

Vedere anche

Altre risorse

Materiale di riferimento per Microsoft System Management Server 2003 Management Pack
Risoluzione dei problemi relativi a SMS 2003 Management Pack


Scenari di monitoraggio del Management Pack

Microsoft® Systems Management Server (SMS) 2003 offre funzionalità nuove e migliorate per il monitoraggio di SMS 2003. Nelle sezioni seguenti vengono descritti gli scenari principali supportati da SMS 2003 Management Pack con una descrizione delle rispettive funzionalità.

Disponibilità dei servizi

Individuazione dei servizi

Monitoraggio della disponibilità

Monitoraggio dello stato

Supporto per il monitoraggio senza agenti

Monitoraggio delle soglie prestazioni

Monitoraggio delle prestazioni

Monitoraggio dei messaggi di stato critico SMS

Monitoraggio del sistema del sito

Monitoraggio dei dettagli arresto anomalo del servizio Executive

Monitoraggio dei backlog

Monitoraggio dello stato generale

Monitoraggio della gestione delle patch di SMS

Monitoraggio del servizio SMS Site Backup

Contenuto della documentazione Product Knowledge relativo a tutti gli avvisi

Gruppi di computer per tutti i ruoli client e server SMS 2003

Monitoraggio esteso

Stato di esecuzione del programma di distribuzione software

Disponibilità dei servizi

Questo scenario consente di monitorare la disponibilità dei servizi SMS 2003 mediante l'apposita funzionalità di System Center Operations Manager 2007 e gli eventi di Gestione controllo servizi nel registro di sistema degli eventi NT. Il monitoraggio della disponibilità dei servizi genera:

  • Un avviso all'arresto di servizi basati su SMS nei sistemi del sito SMS.
  • Un avviso in caso di arresto o errore di avvio di un servizio critico dipendente da SMS, ad esempio Strumentazione gestione Windows (WMI), nei sistemi del sito SMS.
  • Un avviso in caso di arresto o errore di avvio di altri servizi dipendenti da SMS, ad esempio Microsoft SQL Server™, Internet Information Services (IIS) e Servizio trasferimento intelligente in background, nei sistemi del sito SMS.
  • Un avviso all'avvio e all'arresto del servizio SMS Site Backup, affinché sia possibile controllare la durata dei backup e correlare gli eventi di arresto di altri servizi SMS a SMS Site Backup.

Individuazione dei servizi

Questo scenario consiste nell'individuazione di dati, componenti e ruoli server nei computer gestiti. Il processo di individuazione dei servizi restituisce informazioni sui server e i client avanzati di SMS. Supporta inoltre la presentazione dei ruoli client e server SMS nella vista per il monitoraggio dello stato.

I dati di individuazione dei servizi specifici del server vengono raccolti e progressivamente visualizzati nella console System Center Operations Manager dopo la distribuzione del Management Pack. Le funzionalità che richiedono l'identificazione di ruoli, gruppi di computer e computer di destinazione per attività specifiche non sono disponibili fino alla prima esecuzione della raccolta di dati di individuazione dei servizi.

SMS 2003 Management Pack utilizza le regole di elaborazione degli eventi seguenti per avviare gli script per l'individuazione dei servizi:

  • Client SMS\Client SMS - Avanzati\Individuazione servizi SMS 2003
  • Server SMS\Server SMS - Comuni\Individuazione servizi SMS 2003

Gli script utilizzano un provider temporizzato asincrono per raccogliere i dati di individuazione dei servizi una volta ogni 24 ore per impostazione predefinita. Il provider esegue inoltre quanto segue:

  • Distribuzione del Management Pack
  • Modifiche alla configurazione del Management Pack
  • Avvio e arresto dell'agente Operations Manager 2007

Monitoraggio della disponibilità

In questa versione di SMS Management Pack sono disponibili tre report sulla disponibilità: il report Disponibilità server SMS 2003, il report Disponibilità punto di gestione SMS 2003 e il report Disponibilità server sito SMS 2003.

Disponibilità punto di gestione è un report sulla disponibilità basato sullo stato dei componenti, il quale viene eseguito mediante un nuovo algoritmo, nuove regole e lo script SMS 2003 Monitor Management Point Availability.

Tutti i report, inclusi quelli nuovi descritti in questa sezione, vengono eseguiti sul database OperationsManager che consente di specificare durate di report maggiori rispetto allo script precedente, il quale consente soltanto di creare le stored procedure nel database OperationsManager.

Per ulteriori informazioni sulla disponibilità dei server, vedere l'argomento relativo a Script per SMS 2003 e Report per SMS 2003.

Monitoraggio dello stato

Questo scenario offre una rappresentazione grafica dello stato di tutti i server oppure dei server inclusi nell'ambito di determinati gruppi di computer. Il Management Pack supporta questa funzionalità con un elenco specifico di gruppi di computer. I componenti e i ruoli server vengono gestiti tramite l'individuazione dei servizi, mentre lo stato dei componenti viene gestito mediante un set di regole per la disponibilità dei servizi, le soglie prestazioni e lo stato dei punti di gestione.

Nella tabella seguente vengono indicati gli stati monitorati per i componenti SMS in base al colore corrispondente.

Monitoraggio dello stato dei server SMS

Componente SMS | Verde (corretto) | Giallo (avviso) | Rosso (critico)
Server del sito (SS) | Sì | Sì | Sì
Punto di gestione (MP) | Sì | Sì | Sì
Database del sito (DB) | Sì | Sì | Sì
Punto di distribuzione (DP) | Sì |  |
Punto di localizzazione del server (SLP) | Sì |  | Sì
Sender | Sì |  | Sì
Punto di reporting (RP) | Sì |  | Sì
Provider | Sì |  | Sì
Punto di accesso client (CAP) | Sì |  | Sì
Prestazioni | Sì | Sì | Sì
Nota
Non sono disponibili regole di monitoraggio in grado di modificare lo stato del componente punto di distribuzione, pertanto se il componente è presente il suo stato viene indicato solo in verde. Se non è presente alcun punto di distribuzione, tale componente non viene rappresentato nella console.

Monitoraggio dello stato dei client di SMS

Componente SMS | Verde (corretto) | Giallo (avviso) | Rosso (critico)
Servizio client | Sì |  | Sì

Supporto per il monitoraggio senza agenti

SMS 2003 Management Pack supporta il monitoraggio su computer gestiti senza agenti, ad eccezione delle funzionalità seguenti:

  • Monitoraggio dei messaggi di stato critico SMS
  • Monitoraggio dello stato del sistema del sito
  • Topologia

Gli script che supportano le funzionalità indicate sopra sono :

  • SMS 2003 Monitor SMS Status Messages
  • SMS 2003 Monitor Site System Summarizer
  • SMS 2003 Server Topology: Discovery

Tali script devono essere eseguiti localmente sul provider SMS per l'accesso allo spazio dei nomi SMS. Se gli script non sono in grado di individuare lo spazio dei nomi SMS, si verifica un evento di errore.

Monitoraggio delle soglie prestazioni

Livelli di prestazioni ridotti possono determinare ritardi e influenzare negativamente i contratti di servizio degli utenti in termini di tempo, prestazioni e accuratezza dei dati. È importante individuare e risolvere i problemi gravi relativi alle prestazioni nell'infrastruttura SMS. Il monitoraggio delle soglie prestazioni genera un avviso nei casi seguenti:

  • Le metriche generali relative allo stato a livello di computer per quanto concerne CPU, file di paging e memoria nei sistemi del sito SMS superano determinate soglie.
  • Il numero totale di connessioni utente di Microsoft SQL Server™ supera una soglia.
  • Il numero totale di file SMS [ad esempio processi dell'utilità di pianificazione, richieste di invio, record di controllo software, record dei dati di individuazione (DDR) e record di inventario software e hardware] supera determinate soglie nelle cartelle di posta in arrivo del server del sito SMS.
  • Il numero totale di messaggi SMS relativi allo stato, ai record dei dati di individuazione, all'inventario software e a quello hardware nelle code dei messaggi dei punti di gestione SMS supera determinate soglie.

Monitoraggio delle prestazioni

Questo scenario consente di controllare le tendenze nei backlog, nelle frequenze di elaborazione e nei conteggi totali degli oggetti chiave SMS allo scopo di individuare e risolvere attivamente i problemi. Questo tipo di monitoraggio consente di controllare graficamente le tendenze seguenti mediante le viste e i report di Operations Manager 2007:

  • File di backlog nelle cartelle di posta in arrivo riguardanti i processi dell'utilità di pianificazione, le richieste di invio, i record di controllo software, i record dei dati di individuazione, l'inventario hardware, l'inventario software e i messaggi di stato nei server del sito SMS.
  • Frequenze di elaborazione di processi dell'utilità di pianificazione, richieste di invio, record di controllo software, record dei dati di individuazione, inventario hardware, inventario software e messaggi di stato nei server del sito SMS.
  • Numero totale di processi dell'utilità di pianificazione, richieste di invio, record di controllo software, record dei dati di individuazione, inventario hardware, inventario software e messaggi di stato nei server del sito SMS.
  • Backlog di messaggi relativi a record dei dati di individuazione, inventario hardware, inventario software, controllo software, messaggi di stato e altri oggetti SMS nelle code dei messaggi dei server dei punti di gestione SMS.
  • Frequenze di elaborazione di record dei dati di individuazione, inventario hardware, inventario software, controllo software, messaggi di stato e altri oggetti SMS nelle code dei messaggi dei server dei punti di gestione SMS.
  • Numero totale di record dei dati di individuazione, inventario hardware, inventario software, inoltri e messaggi di stato SMS nelle code dei messaggi dei server dei punti di gestione SMS.
  • Numero totale di connessioni utente di SQL Server nei server di database del sito SMS.
  • Metriche relative allo stato a livello di computer per quanto concerne CPU, file di paging e memoria nei sistemi del sito SMS.
  • Numero totale di thread del servizio SMS Executive in esecuzione.
  • Frequenza delle richieste di estensione ISAPI a IIS.

Monitoraggio dei messaggi di stato critico SMS

L'infrastruttura SMS genera messaggi sullo stato di SMS. È importante individuare i messaggi di stato critico SMS relativi ai server e risolverli tempestivamente. Tali messaggi indicano in genere problemi in termini di disponibilità, prestazioni, configurazione e stato generale dell'infrastruttura SMS.

Questo tipo di monitoraggio genera un avviso quando vengono rilevati messaggi di stato critico relativi al ruolo del sito SMS (ad esempio per installazioni di componenti, connettività del database e del sito). Viene eseguita una ricerca di messaggi di stato critico SMS nel database del sito SMS ogni 30 minuti.

Monitoraggio dello stato del sistema del sito

SMS controlla regolarmente lo stato di base dei sistemi del sito tramite il servizio Site System Status Summarizer, il quale esegue il polling dei sistemi del sito SMS allo scadere di ogni ora. Per sfruttare al meglio i vantaggi di questa funzionalità, è necessario agire rapidamente sullo stato in modo da impedire riduzioni di funzionalità di SMS. Questo tipo di monitoraggio consente di controllare e generare avvisi quando viene rilevato uno stato critico del sistema del sito SMS da parte del servizio SMS Site System Summarizer. Alcuni dei messaggi di stato monitorati sono relativi all'inattività del sistema del sito SMS, all'esaurimento dello spazio di database o di log in un server che esegue SQL Server e all'esaurimento dello spazio su disco fisico nei sistemi del sito SMS.

Monitoraggio dei dettagli arresto anomalo del servizio Executive

Gli errori del servizio SMS Executive influenzano la disponibilità di SMS ed è importante sapere quando si verificano gli arresti anomali per analizzarne le cause principali. Quando si verifica un problema nel servizio SMS Executive, viene creata una sottodirectory del registro dei dettagli arresto anomalo nella directory SMS\Logs\CrashDumps. La creazione di questa sottodirectory viene monitorata e viene generato un avviso per qualsiasi ruolo server SMS dipendente dal servizio SMS Executive.

Lo script Monitor SMS Executive Crash Dumps di SMS 2003 segnala solo gli arresti anomali più recenti. Ciò si applica indipendentemente dal tempo trascorso dall'ultimo arresto anomalo, a partire dalla prima esecuzione dello script fino all'eventuale disinstallazione e successiva reinstallazione di SMS Executive.

Le regole correlate si trovano nel gruppo di regole Server componente Microsoft SMS 2003 basati su SMS Executive:

  • Dettagli arresto anomalo SMS 2003: monitoraggio di SMS Executive

Dettagli arresto anomalo SMS 2003: monitoraggio di SMS Executive avvia lo script mediante il provider di eventi temporizzato SMS 2003 Schedule every 60 minutes synchronize at 00:10. Le informazioni di riepilogo sono disponibili nella pagina delle proprietà Knowledge della regola.

  • Dettagli arresto anomalo SMS 2003: monitoraggio errore script SMS Executive

Dettagli arresto anomalo SMS 2003: monitoraggio errore script SMS Executive controlla eventuali eventi di errore di script e genera appositi avvisi. Esiste un solo evento di errore di script, il numero 1102, che segnala tutti gli errori di script. Le informazioni sulla risoluzione dell’avviso sono disponibili nella pagina delle proprietà Knowledge della regola.

  • Dettagli arresto anomalo SMS 2003: arresto anomalo di SMS Executive

Dettagli arresto anomalo SMS 2003: arresto anomalo di SMS Executive controlla gli eventi di arresto anomalo e genera gli appositi avvisi. Le informazioni sulla risoluzione dell’avviso sono disponibili nella pagina delle proprietà Knowledge della regola.

Monitoraggio dei backlog

I backlog determinano ritardi che influenzano i contratti di servizio degli utenti in termini di tempo, prestazioni e accuratezza dei dati. È importante individuare e risolvere tempestivamente i problemi gravi relativi alle prestazioni nell'infrastruttura SMS. Viene generato un avviso quando un backlog supera una soglia in un periodo di tempo specifico relativamente a quanto segue:

  • Numero totale di file SMS, ad esempio processi dell'utilità di pianificazione, richieste di invio, record di controllo software, record dei dati di individuazione (DDR) e record di inventario software e hardware, nelle cartelle di posta in arrivo del server del sito SMS.
  • Numero totale di oggetti SMS, ad esempio processi dell'utilità di pianificazione, richieste di invio, record di controllo software, record dei dati di individuazione (DDR) e record di inventario software e hardware, nelle code del server del sito SMS.

Numero totale di messaggi SMS relativi allo stato, ai record dei dati di individuazione, all'inventario software e a quello hardware nelle code dei messaggi dei punti di gestione SMS.

Monitoraggio dello stato generale

Questo tipo di monitoraggio genera un avviso quando una metrica relativa allo stato in un server SMS supera una determinata soglia in un periodo di tempo dato. Vengono monitorate le metriche seguenti:

  • Processor Time at 95% over three hours
    • Smsexec
    • Ccmexec
    • Total
  • Paging File Usage at 98% over three hours

Monitoraggio della gestione delle patch di SMS

Gli amministratori di SMS fanno affidamento sulle funzionalità di gestione delle patch di SMS per distribuire gli aggiornamenti della protezione più recenti nei computer server e client delle rispettive organizzazioni. Questo tipo di monitoraggio consente di rilevare eventuali errori nella configurazione e nell'elaborazione della gestione delle patch di SMS. Viene generato un avviso nei casi seguenti:

  • Il processo di sincronizzazione della gestione delle patch SMS ha esito negativo.
  • Il processo di gestione delle patch di SMS non è in grado di fornire gli aggiornamenti ai punti di distribuzione SMS.

Monitoraggio del servizio SMS Site Backup

Conoscendo gli orari di avvio, completamento o errore dei backup di SMS 2003, gli amministratori di SMS possono controllare le attività di backup. È possibile pianificare l'esecuzione periodica dei backup di dati, criteri e configurazioni di SMS. È importante monitorare gli errori del processo di backup e adottare le necessarie azioni correttive. Anche in caso di esito positivo, il processo di backup di SMS influenza la disponibilità dei servizi in quanto determina l'arresto e il riavvio dei servizi SMS Site Component Manager, SMS Executive e SMS SQL Monitor. Il monitoraggio dei backup di SMS consente di tenere traccia dei tempi di inattività di tali servizi poiché gli avvisi relativi al loro arresto vengono sospesi durante il processo di backup. Il monitoraggio del servizio di backup SMS Site Backup è supportato dalle regole seguenti:

  • Interruzione servizio SMS 2003: SMS_SITE_BACKUP
  • Avvio servizio SMS 2003: SMS_SITE_BACKUP
  • Stato SMS 2003: backup sito completato
  • Stato SMS 2003: backup sito non riuscito

Contenuto della documentazione Product Knowledge relativo a tutti gli avvisi

Gli amministratori possono fare riferimento al contenuto della documentazione Product Knowledge per ottenere informazioni su tutti gli avvisi, grazie alle quali identificare e risolvere i problemi. Per accedere a tale contenuto, fare clic con il pulsante destro del mouse su una regola qualsiasi, scegliere Properties e quindi fare clic sulla scheda Product Knowledge.

Gruppi di computer per tutti i ruoli client e server SMS 2003

La risoluzione dei gruppi di computer è ora impostata in specifici ruoli client e server SMS. Ciò offre agli amministratori maggiore controllo nella gestione della replica delle regole negli agenti Operations Manager 2007. Gli amministratori possono disattivare i gruppi di computer predefiniti oppure definirne di nuovi in base ai gruppi e attributi di computer predefiniti.

Monitoraggio esteso

Le regole disponibili in SMS 2003 Management Pack consentono di eseguire le attività di monitoraggio relative alle soglie prestazioni e alla misurazione di queste ultime per SQL Server Management Pack, IIS Management Pack e i Management Pack di base dei sistemi operativi Microsoft Windows® 2000 e Windows Server® 2003. È possibile attivare il supporto di base in SMS 2003 Management Pack per tali Management Pack oppure mantenere disattivate le impostazioni e attivare le apposite regole in altri Management Pack.

  • Utilizzare SQL Server Management Pack per espandere il monitoraggio dei punti di gestione e dei server di database del sito SMS con dipendenze da SQL Server.
  • Utilizzare IIS Management Pack per monitorare IIS nei punti di reporting, nei punti di gestione e nei punti di localizzazione server. IIS Management Pack è inoltre in grado di monitorare i punti di distribuzione in cui è attivato il server BITS.
  • Utilizzare il Management Pack di base dei sistemi operativi Microsoft Windows 2000 e Windows Server 2003 per monitorare i componenti di base di Windows, quali statistiche su memoria, CPU e dischi.

Esistono altri Management Pack, per i quali SMS 2003 Management Pack non include regole, i quali consentono di migliorare il monitoraggio dell'infrastruttura SMS 2003.

  • Utilizzare il Management Pack di Bilanciamento carico di rete di Windows se si utilizza Bilanciamento carico di rete per supportare più punti di gestione nella gerarchia SMS per motivi di scalabilità.
  • Utilizzare Windows Active Directory® Directory Management Pack per monitorare lo stato dell'infrastruttura Active Directory.

Se si distribuiscono più Management Pack nell'ambiente in uso, potrebbero essere generati avvisi ridondanti a seconda delle regole esistenti nei Management Pack stessi. Se si disattivano le regole di monitoraggio ridondanti, l'accuratezza delle viste sullo stato relative ai Management Pack distribuiti potrebbe risentirne. È necessario valutare con attenzione i vantaggi e gli svantaggi della ricezione di avvisi ridondanti e mantenere attivo il monitoraggio dello stato per tutti i Management Pack distribuiti. A seconda dei Management Pack aggiuntivi che vengono distribuiti, è consigliabile esaminare le regole ridondanti per identificare quelle che possono essere eventualmente attivate nell'ambiente in uso. Dopo l'installazione dei Management Pack, verificare che essi siano personalizzati in base alle necessità, configurati correttamente e che le regole appropriate siano attivate.

Stato di esecuzione del programma di distribuzione software

Il client avanzato di SMS è in grado di segnalare errori dei programmi tramite il Management Pack.

Gli amministratori possono selezionare la casella di controllo Generate MOM alert if this program fails nella scheda MOM della finestra di dialogo Program Properties.

Procedura

Per attivare gli avvisi di Operations Manager 2007 in caso di errore di un programma SMS 2003, è necessario eseguire la procedura seguente:

Per attivare gli avvisi di Operations Manager 2007 per un programma SMS 2003

  1. Nella console Systems Management Server passare a Systems Management Server / Site Database - <nome del server del sito> / Packages.

  2. Nel riquadro dei dettagli fare clic con il pulsante destro del mouse su Program e scegliere Properties. Verrà visualizzata la finestra di dialogo delle proprietà del programma.

  3. Fare clic sulla scheda MOM.

  4. Selezionare la casella di controllo Generate MOM alert if this program fails to run. Fare clic su OK.

Vedere anche

Concetti

Distribuzione di SMS 2003 Management Pack

Altre risorse

Materiale di riferimento per Microsoft System Management Server 2003 Management Pack


Distribuzione di SMS 2003 Management Pack

Prima di distribuire Microsoft® Systems Management Server (SMS) 2003 Management Pack, vedere la guida alla distribuzione di Microsoft Operations Manager 2007 disponibile nella pagina Web relativa a Operations Manager 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=83259. In questa sezione vengono illustrate ulteriori istruzioni per la distribuzione dei Management Pack di Operations Manager.

Per distribuire SMS 2003 Management Pack, è necessario completare le procedure seguenti:

  • Distribuire l'agente Operations Manager 2007 in tutti i computer componenti server di SMS.
Nota
Se è richiesto il mapping della topologia o la modalità manutenzione di Operations Manager 2007, è necessario distribuire SMS 2003 SP3 prima di importare SMS 2003 Management Pack o di installare l'agente Operations Manager 2007.

  • Importare SMS 2003 Management Pack in un gruppo di configurazione di Operations Manager 2007.
  • Configurare i provider SMS e i server di database del sito SMS affinché gli agenti Operations Manager 2007 possano essere utilizzati come proxy per altri computer.
  • Eseguire le attività di testing e le attività per il progetto pilota.
  • Eseguire le attività di ottimizzazione consigliate.

Contenuto della sezione

Distribuzione dell'agente Microsoft Operations Manager 2007

Testing e progetto pilota per SMS 2003 Management Pack

Personalizzazione del Management Pack

Vedere anche

Concetti

Scenari di monitoraggio del Management Pack

Altre risorse

Panoramica di System Management Server 2003 Management Pack
Esecuzione di attività operative per SMS 2003 Management Pack
Risoluzione dei problemi relativi a SMS 2003 Management Pack
Materiale di riferimento per Microsoft System Management Server 2003 Management Pack


Distribuzione dell'agente Microsoft Operations Manager 2007

L'agente Microsoft Operations Manager viene eseguito su tutti i computer monitorati da Operations Manager. Per visualizzare i gruppi di computer monitorati con SMS 2003 Management Pack, vedere la sezione Gruppi di computer per SMS 2003 in questa guida. L'agente Microsoft Operations Manager 2007 raccoglie i dati del monitoraggio nel computer gestito, applica regole ai dati raccolti e quindi invia i dati risultanti al Data Consolidator Agent Manager (DCAM). La funzionalità di monitoraggio in un computer agente è disponibile nel servizio Operations Manager 2007 (HealthService.exe), nell'host Operations Manager 2007 (MonitoringHost.exe) e nell’account azione agente.

Per distribuire l'agente Microsoft Operations Manager 2007, è possibile utilizzare l'installazione guidata di Operations Manager 2007 o la distribuzione software SMS. Per ulteriori informazioni sulla distribuzione dell'agente Microsoft Operations Manager 2007 e sull'utilizzo dell'installazione guidata di Operations Manager 2007, vedere l'argomento relativo all'individuazione dei computer e alla distribuzione di agenti MOM nella guida di distribuzione di Microsoft Operations Manager 2007. Per ulteriori informazioni, vedere la pagina Web Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).

Nota
È consigliabile eseguire l'agente Microsoft Operations Manager 2007 nei computer provider SMS tramite l'account LocalSystem o un account con diritti sufficienti per accedere alla radice degli spazi dei nomi WMI di SMS 2003, radice\cimv2, radice\sms, alla chiave del Registro di sistema di SMS e alle relative sottochiavi.

Per determinare se è possibile utilizzare il monitoraggio senza agente nell'ambiente in uso, vedere Supporto per il monitoraggio senza agente in Scenari di monitoraggio del Management Pack.

Configurazione dei computer agente per l'esecuzione in scenari con privilegi di basso livello

La funzionalità di monitoraggio in un computer agente è disponibile nel servizio Operations Manager 2007 (HealthService.exe), nell'host Operations Manager 2007 (MonitoringHost.exe) e nell’account azione agente. In Microsoft Windows® 2000 l'account azione deve essere membro del gruppo degli amministratori locali. In Microsoft Windows™ 2003 è possibile utilizzare un account con privilegi di basso livello come account azione dell'agente in determinate circostanze. La configurazione dell'account azione e del contesto utente in cui vengono eseguiti il servizio Operations Manager 2007 e l'host Operations Manager 2007 con i diritti e le autorizzazioni necessarie per l'esecuzione delle funzionalità di SMS 2003 Management Pack richiede tuttavia numerose operazioni di configurazione manuali nel computer agente. In Microsoft Windows Server™ 2003 l'account azione dell'agente deve disporre dei diritti utente e delle autorizzazioni minime seguenti:

  • Membro del gruppo degli utenti locali
  • Accesso ai registri eventi di Windows
  • Autorizzazione di gestione dei registri di controllo e di protezione (SeSecurityPrivilege)
  • Autorizzazione di generazione dei controlli di protezione (SeAuditPrivilege)
  • Autorizzazione Consenti accesso locale (SeInteractiveLogonRight)

In uno scenario con privilegi di basso livello, SMS 2003 Management Pack richiede che l'account utilizzato come account azione dell'agente disponga di diritti e autorizzazioni aggiuntive. Nella tabella seguente sono indicati i diritti di accesso da configurare manualmente.

Tipi di accesso necessari per SMS 2003 Management Pack

Risorsa | Tipo di accesso | Istruzioni
Registro eventi di Windows | Lettura | È necessario concedere all'account azione il privilegio per la gestione del controllo e del registro di protezione utilizzando i criteri locali o globali.
Chiavi del Registro di sistema di SMS | Lettura | HKLM\Software\Microsoft\SMS Aggiungere l'account azione alle proprietà del Registro di sistema e concedere l'accesso in lettura ereditato da tutte le sottochiavi.
Chiavi del Registro di sistema dei servizi di Win32 | Lettura | HKLM\System\CurrentControlSet\Services Aggiungere l'account azione al gruppo degli utenti locali.
File temporanei generati da script | Lettura e scrittura | %Windir%\Temp Aggiungere l'account azione al gruppo degli utenti locali. .
File di registro generati da script | Lettura e scrittura | %Windir%\Microsoft Operations Manager Aggiungere l'account azione alle proprietà della cartella.
File di registro di SMS | Lettura | \SMS\Logs Aggiungere l'account azione alle proprietà della cartella.
Spazi dei nomi WMI | Lettura | radice e radice\cimv2 Non sono necessarie operazioni.
Spazi dei nomi WMI di SMS | Lettura | Non sono necessarie operazioni.
Classi WMI di SMS | Lettura | SMS_Site SMS_R_System SMS_SystemResourceList SMS_SiteSystemSummarizer Aggiungere l'account azione alla classe per tutte le istanze
Diritti di accesso con protezione per l'istanza predefinita | Concedi accesso | Per l'istanza predefinita in un computer SQL Server gestito, l'account azione deve disporre dei diritti Concedi accesso per l'accesso con protezione. In SQL Server Enterprise Manager aggiungere l'account azione al nodo nomeistanza\Security\Logins.
Accesso al database master nell'istanza predefinita (necessario per identificare il database di sito SMS) | Autorizza | Per l'istanza predefinita in un computer SQL Server gestito, l'account azione deve disporre del diritto di autorizzazione dell'accesso al database master. In SQL Server Enterprise Manager aggiungere l'account azione al nodo nomeistanza\Databases\Master\Users. Mantenere tutte le autorizzazioni predefinite associate a questo nuovo utente.
Accesso al database di sito SMS nell'istanza predefinita | Autorizza | Per l'istanza predefinita in un computer SQL Server gestito, l'account azione deve disporre del diritto di autorizzazione dell'accesso al database del sito SMS. In SQL Server Enterprise Manager aggiungere l'account azione al nodo nomeistanza\Databases\<SMS site>\Users. Mantenere tutte le autorizzazioni predefinite associate a questo nuovo utente.

Vedere anche

Concetti

Testing e progetto pilota per SMS 2003 Management Pack
Personalizzazione del Management Pack
Problemi noti di SMS 2003

Altre risorse

Risoluzione dei problemi relativi a SMS 2003 Management Pack


Testing e progetto pilota per SMS 2003 Management Pack

Oltre ai consigli generali per i test dei Management Pack descritti nella guida alla distribuzione di Microsoft Operations Manager 2007, in questa sezione sono elencate le attività per il testing e il progetto pilota appropriate per SMS 2003 Management Pack. Per ulteriori informazioni, vedere la pagina Web Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).

Attività per il testing

  • Verificare che i gruppi di computer SMS 2003 siano popolati con i computer che eseguono SMS 2003.
  • Dopo aver attivato le regole rilevanti, verificare che le viste e i report in Operations Manager 2007 funzionino correttamente. Sono incluse le viste relative alle frequenze di elaborazione di SMS e ai backlog di SMS.
  • Per impostazione predefinita, alcune regole relative ad altri Management Pack, ad esempio i Management Pack di IIS e SQL Server, sono disattivate in SMS 2003 Management Pack. A seconda degli altri Management Pack distribuiti, è necessario controllare tali regole disattivate per identificare eventuali regole che si desidera attivare nell'ambiente in uso.
  • Per impostazione predefinita, tutte le regole di controllo delle prestazioni sono disattivare per ridurre al minimo l'impatto sulla CPU, sulla memoria e sulle risorse di rete dell'agente. È possibile attivare queste regole per un monitoraggio più approfondito dell’agente.
  • Alcuni degli script SMS che vengono eseguiti in un computer provider SMS o in un server di database del sito SMS oppure che accedono a un database del sito SMS non vengono eseguiti in modalità senza agente. Verificare che tutti i computer dei gruppi di computer Microsoft SMS 2003 Provider e Microsoft SMS Site Database Server siano configurati come gestiti con l'agente. Inoltre, poiché alcuni di questi script potrebbero inoltrare eventi, verificare che tali agenti siano configurati per consentire l'inoltro dei dati.

Attività per il progetto pilota

  • Verificare che il processo di distribuzione o di aggiornamento dalla versione precedente con SMS 2003 Management Pack sia stato completato correttamente.
  • Verificare e modificare le soglie personalizzate per il proprio ambiente tramite la visualizzazione di Health Monitor della soglia prestazioni.
  • Attivare le regole per le prestazioni in varie fasi per valutare l'impatto di tali regole sulle prestazioni di Operations Manager 2007.
  • Verificare che i gruppi di computer SMS 2003 siano popolati con i computer che eseguono SMS 2003.
  • Dopo aver attivato le regole rilevanti, verificare che le viste e i report in Operations Manager 2007 funzionino correttamente. Sono incluse le viste relative alle frequenze di elaborazione, ai totali di elaborazione e ai backlog di SMS.
  • Per impostazione predefinita, alcune regole relative ad altri Management Pack sono disattivate. A seconda degli altri Management Pack distribuiti, è necessario controllare le regole disattivate per identificare eventuali regole che si desidera attivare nell'ambiente in uso.
  • Per impostazione predefinita, alcune regole relative alle prestazioni sono disattivare per ridurre al minimo l'impatto sulla CPU, sulla memoria e sulle risorse di rete dell'agente. È possibile attivare queste regole per un monitoraggio più approfondito dell’agente.
  • Verificare che non vengano generati eventi basati sull'esecuzione di script SMS 2003. Tali eventi indicano in genere problemi relativi alle autorizzazioni di accesso per lo script.
  • Verificare che le dimensioni di DCAM e SQL Server siano sufficienti per il carico di produzione.
  • Verificare i processi operativi e i requisiti del personale.
  • Verificare che il paging e le notifiche tramite posta elettronica funzionino correttamente.
  • Verificare che le autorizzazioni utilizzate da Operations Manager 2007 siano sufficienti per una corretta esecuzione, senza essere eccessive.
  • Se non viene specificato che l'agente Microsoft Operations Manager 2007 venga eseguito con l'account LocalSystem, assicurarsi che siano stati applicati i diritti di protezione minimi. Per ulteriori informazioni, vedere la sezione "Configurazione dei computer agente per l'esecuzione in scenari con privilegi di basso livello" in Distribuzione dell'agente Microsoft Operations Manager 2007 in questa guida.
  • Verificare che i ruoli SMS Server e SMS Client siano presenti nella visualizzazione State. Fare clic su un computer che ospita ciascuno di questi ruoli e verificare che i componenti siano visibili nel riquadro dell'istanza.
  • Verificare che le attività della console di amministrazione SMS funzionino facendo clic su un'attività. Se l'attività non viene eseguita, controllare che la console di amministrazione SMS 2003 SP2 sia stata installata e che l'utente connesso si sia disconnesso, quindi abbia eseguito nuovamente l'accesso alla console al termine dell'installazione.
  • Nella visualizzazione State fare clic su un server SMS e su un client SMS per verificare che nella pagina Roles vengano visualizzati i ruoli e i dati delle proprietà appropriati.
  • Nel riquadro Monitoring passare a Microsoft Systems Management Server (SMS) 2003 e quindi fare clic su SMS 2003 Site Hierarchy Diagram. Verificare che tutti i sistemi del sito vengano visualizzati per i siti in cui è installato localmente l'agente Microsoft Operations Manager 2007 nel relativo provider SMS. Se un sistema del sito non viene visualizzato, aprire la console di amministrazione SMS per controllare se il sistema del sito è stato individuato dal sito ed è presente nell'insieme All Systems.

Al termine del progetto pilota, esportare SMS 2003 Management Pack per eseguire il backup delle modifiche apportate.

Vedere anche

Concetti

Personalizzazione del Management Pack
Distribuzione dell'agente Microsoft Operations Manager 2007
Problemi noti di SMS 2003

Altre risorse

Risoluzione dei problemi relativi a SMS 2003 Management Pack


Personalizzazione del Management Pack

Per ottenere un monitoraggio ottimale, è possibile personalizzare SMS 2003 Management Pack in base alle esigenze della propria organizzazione. Se le regole esistenti non soddisfano i requisiti aziendali, modificarle o crearne di nuove.

Nota Eseguire sempre il backup di SMS 2003 Management Pack prima di apportare modifiche. L'esportazione guidata Operations Manager 2007 Management Pack consente di eseguire il backup dei Management Pack per cui non è stato eseguito il sealing.

Le operazioni di personalizzazione possono includere:

  • Attivazione e disattivazione di regole tramite override.
  • Creazione di nuove regole.
  • Modifica dei criteri degli avvisi, della gravità degli avvisi ed eliminazione degli avvisi.
  • Impostazione di soglie personalizzate per le regole. Tutte le regole di soglia prestazioni possono essere configurate. Se la soglia predefinita non è ottimale, è possibile che vengano visualizzati avvisi non necessari o che non ne vangano visualizzati nel caso in cui la soglia sia troppo elevata per l'ambiente corrente.
  • Configurazione della soglia della regola degli eventi di monitoraggio della posta in arrivo e dell'intervallo di polling tramite override o, nel caso di valori di soglia, modificando la visualizzazione XML.
  • Aggiunta di una nuova regola degli eventi di monitoraggio della posta in arrivo. Per aggiungere una nuova regola di monitoraggio della posta in arrivo, creare una nuova regola nel Management Pack predefinito, quindi creare gli override per i parametri di input dello script (FileCountThreshold e InboxDirectoryName) e pianificare.
  • Impostazione degli intervalli di polling per il controllo delle prestazioni tramite override.
  • Aggiunta di contenuto alla Knowledge Base della società.
  • Personalizzazione delle risposte agli avvisi tramite la modifica o l'aggiunta di nuove risposte alle regole o l'aggiunta di regole di elaborazione degli avvisi per tali avvisi.
  • L'attivazione delle regole di controllo delle prestazioni nell'agente, nel server che esegue Operations Manager 2007 e nel database genera una quantità elevata di dati e può provocare problemi nelle prestazioni. Le regole di controllo delle prestazioni sono disattivate per impostazione predefinita per consentire all'utente di decidere se un eventuale impatto sulle prestazioni sia accettabile. Controllare le regole relative alle prestazioni e attivarle in piccoli batch, per poter valutare l'impatto di tali regole sulle prestazioni di Operations Manager 2007 e sulle dimensioni del database.
  • Impostazione dei parametri per le regole degli eventi di monitoraggio della posta in arrivo e delle regole correlate. Modificare i due script FileCountThreshold e InboxDirectoryName, creando un override.
  • Controllo dell'applicabilità delle regole nell'ambiente corrente. Per impostazione predefinita, alcune regole relative ad altri Management Pack sono disattivate. A seconda degli altri Management Pack distribuiti, è necessario controllare le regole disattivate per identificare eventuali regole che si desidera attivare nell'ambiente in uso.

Per ulteriori informazioni sulla personalizzazione dei Management Pack e su come esportare le personalizzazioni, vedere gli argomenti relativi ai Management Pack in Operations Manager 2007 e all'esportazione delle personalizzazioni dei Management Pack nella Guida di Operations Manager 2007.

Monitoraggio della posta in arrivo

L'esportazione guidata Operations Manager 2007 consente di salvare le modifiche nel Management Pack predefinito prima di apportare ulteriori modifiche.

Configurazione delle regole di monitoraggio della posta in arrivo

Per distribuire queste regole in server del sito centrali, primari e secondari, è necessario creare nuove regole nel Management Pack basate sulle regole di SMS Site Servers - Common. È quindi possibile assegnare tali regole al gruppo di regole di elaborazione appropriato per il server del sito, modificare la soglia e attivare la regola.

  • SMS 2003 Inbox: Monitor inbox
  • SMS 2003 Inbox: Monitor inbox script error
  • SMS 2003 Inbox: Threshold exceeded

Regola di elaborazione degli eventi SMS 2003 Inbox: Threshold exceeded per lo script SMS 2003: Monitor Inbox script error. Viene generato un unico avviso per ogni cartella della posta in arrivo che oltrepassa la soglia specificata.

La soglia predefinita per questo script è 10.000 file per ogni cartella. È possibile creare un override per questo valore nel Management Pack predefinito per questo o altri parametri dello script. Se la soglia viene superata, verrà generato un evento “threshold exceeded”. È possibile modificare le impostazioni di soglia calcolando il carico giornaliero previsto sui server per ogni processo funzionante e quindi aggiungere una percentuale accettabile di buffer. Le regole di monitoraggio della posta in arrivo vengono eseguite una volta al giorno per impostazione predefinita, in incrementi di 15 minuti a partire dalle ore 01.00. Per ridurre al minimo l'impatto sulle prestazioni, è consigliabile mantenere questo intervallo o impostarlo in modo da ridurre la sovrapposizione dell'esecuzione degli script tra le regole di monitoraggio della posta in arrivo.

Nella tabella seguente sono elencate le regole di monitoraggio della posta in arrivo, le soglie predefinite e le cartelle della posta in arrivo monitorate dal provider SMS Executive.

Monitoraggio della posta in arrivo di SMS Executive

Nome regola di monitoraggio della posta in arrivo | Soglia predefinita | Nome cartella
SMS 2003 Inbox: Monitor inbox script error | N/D | N/D
SMS 2003 Inbox: Threshold exceeded | N/D | N/D
SMS 2003 Inbox: Monitor auth\dataldr.box | 10000 | Inboxes\auth\dataldr.box
SMS 2003 Inbox: Monitor auth\ddm.box | 10000 | Inboxes\auth\ddm.box
SMS 2003 Inbox: Monitor auth\sinv.box | 10000 | Inboxes\auth\sinv.box
SMS 2003 Inbox: Monitor compsumm.box\repl | 10000 | Inboxes\ compsumm.box\repl
SMS 2003 Inbox: Monitor dataldr.box | 10000 | Inboxes\ dataldr.box
SMS 2003 Inbox: Monitor ddm.box | 10000 | Inboxes\ ddm.box
SMS 2003 Inbox: Monitor despoolr.box\receive | 10000 | Inboxes\despoolr.box\receive
SMS 2003 Inbox: Monitor offermgr.box\INCOMING | 10000 | Inboxes\offermgr.box\INCOMING
SMS 2003 Inbox: Monitor offersum.box\repl | 10000 | Inboxes\ offersum.box\repl
SMS 2003 Inbox: Monitor replmgr.box\incoming | 10000 | Inboxes\replmgr.box\incoming
SMS 2003 Inbox: Monitor schedule.box\outboxes\LAN | 10000 | Inboxes\ schedule.box\outboxes\LAN
SMS 2003 Inbox: Monitor statmgr.box\statmsgs | 10000 | Inboxes\statmgr.box\statmsgs
SMS 2003 Inbox: Monitor swmproc.box\usage | 10000 | Inboxes\swmproc.box\usage

Procedura per eseguire l'override delle regole degli eventi di monitoraggio della posta in arrivo

Prima di eseguire l'override di una regola degli eventi di monitoraggio della posta in arrivo, è necessario che il server del sito Operations Manager 2007 individui gli oggetti del server del sito SMS 2003 di tipo Microsoft SMS 2003 Site Servers.

Per eseguire l'override delle regole degli eventi di monitoraggio della posta in arrivo

  1. In Operations Console di Operations Manager 2007 fare clic sul pulsante Creazione e modifica.

  2. Passare a Creazione e modifica/Oggetti Management Pack/Regole.

  3. Ambito per i server del sito Microsoft SMS 2003.

  4. Fare clic con il pulsante destro del mouse su una regola degli eventi di monitoraggio della posta in arrivo di SMS 2003 appropriata, ad esempio SMS 2003 Inbox: Moinitor schedule box\requests, scegliere Sostituzioni, fare clic su Sostituisce regola e quindi su Tutti gli oggetti di tipo: Microsoft SMS 2003 Site Server.

  5. In Sostituisci proprietà selezionare la casella di controllo di override Attivato e impostare Impostazioni sostituzioni su True.

  6. In Sostituisci proprietà selezionare la casella di controllo di override FileCountThreshold e impostare Impostazioni sostituzioni sul valore di soglia desiderato.

  7. Fare clic su OK. Fare clic su OK. I valori di soglia modificati vengono distribuiti ai server.

Procedura per modificare il monitoraggio della soglia dei contatori delle prestazioni

Per modificare il monitoraggio della soglia dei contatori delle prestazioni attenersi alla procedura seguente.

Per modificare il monitoraggio della soglia dei contatori delle prestazioni

  1. In Operations Console di Operations Manager 2007 fare clic sul pulsante Creazione e modifica.

  2. Passare a Creazione e modifica/Oggetti Management Pack/Monitoraggi.

  3. Modificare l'ambito impostando SMS Server.

  4. Passare a SMS Server / Entity Health / MOM 2005 Computer Role Health e quindi selezionare il ruolo del computer appropriato, ad esempio SS per il server del sito.

  5. Fare doppio clic sulla regola di monitoraggio della soglia prestazioni da modificare. Verrà visualizzata la finestra di dialogo Proprietà per i valori soglia delle prestazioni.

  6. Selezionare la scheda Configurazione.

  7. Fare clic su Modifica. Verrà visualizzata la finestra di dialogo Configurazione XML.

  8. Nel testo XML modificare il valore di soglia appropriato.

    • Specificare il valore <ValueExpression> nidificato in <CriticalErrorExpression> per modificare la soglia degli errori critici.
    • Specificare il valore <ValueExpression> nidificato in <WarningExpression> per modificare la soglia degli avvisi.

  9. Fare clic su OK. Fare clic su OK. I valori di soglia modificati vengono distribuiti ai server.

Vedere anche

Concetti

Testing e progetto pilota per SMS 2003 Management Pack
Configurazione di SMS supportata
Scenari di monitoraggio del Management Pack

Altre risorse

Risoluzione dei problemi relativi a SMS 2003 Management Pack
Materiale di riferimento per Microsoft System Management Server 2003 Management Pack


Esecuzione di attività operative per SMS 2003 Management Pack

È consigliabile analizzare e risolvere tutti gli avvisi per identificare quelli più importanti o critici. È inoltre consigliabile eseguire regolarmente altre attività a seconda dell'ambiente in uso. Numerosi problemi importanti non generano avvisi, ma richiedono un'attenzione periodica. Microsoft® Systems Management Server (SMS) 2003 Management Pack include viste e report che consentono di visualizzare i dati in un lasso di tempo e offrono modelli che indicano problemi. Analizzare viste e report per risolvere i problemi prima che vengano generati avvisi.

È consigliabile eseguire attività quotidiane, settimanali e mensili, come indicato in questa sezione, regolandone tuttavia la frequenza in base alle esigenze dell'ambiente in uso.

In questa sezione

Attività quotidiane per SMS 2003

Attività settimanali per SMS 2003

Attività mensili per SMS 2003

Attività della console di amministrazione SMS 2003

Vedere anche

Concetti

Scenari di monitoraggio del Management Pack
Distribuzione di SMS 2003 Management Pack

Altre risorse

Panoramica di System Management Server 2003 Management Pack
Esecuzione di attività operative per SMS 2003 Management Pack
Risoluzione dei problemi relativi a SMS 2003 Management Pack
Materiale di riferimento per Microsoft System Management Server 2003 Management Pack


Attività quotidiane per SMS 2003

È consigliabile eseguire le attività seguenti ogni giorno:

  • Esaminare tutti gli avvisi aperti.
  • Verificare l'appartenenza al gruppo di computer.
  • Verificare che tutti gli agenti Operations Manager 2007 comunichino con il server Operations Manager 2007.
  • Esaminare i backlog delle prestazioni.
  • Esaminare le frequenze di elaborazione delle prestazioni.
  • Controllare le prestazioni del server e degli agenti Operations Manager 2007.
  • Verificare l'appartenenza al gruppo di notifica o i gruppi di notifica delle regole di elaborazione.
  • Verificare i backup dei siti SMS 2003.
  • Esaminare gli eventi (facoltativo).

Esaminare tutti gli avvisi aperti

Gli avvisi in SMS 2003 Management Pack vengono visualizzati nel formato di descrizione seguente:

$Computer$ <Rule Name>

$Description$

Event details

Esaminare tutti gli avvisi in Operations Manager 2007 per accertarsi che siano stati risolti tempestivamente. Per esaminare gli avvisi aperti, è possibile utilizzare uno o più dei modi seguenti:

  • Nella console operatore fare clic sul pulsante Monitoraggio, espandere Microsoft Systems Management Server (SMS) 2003 e fare clic su Avvisi.
  • In Operations Console fare clic sul pulsante Monitoraggio, espandere Microsoft Systems Management Server (SMS) 2003 e fare clic su Generale. Selezionare la categoria degli avvisi generati nelle ultime 72 ore.
  • Gli avvisi possono essere visualizzati per computer o gruppo di computer facendo clic su Computer e gruppi. Per visualizzare un riepilogo in base alla gravità degli avvisi, fare clic con il pulsante destro del mouse sul gruppo di computer SMS 2003 che si desidera esaminare, scegliere Visualizza e quindi Avvisi.
  • È possibile visualizzare gli avvisi tramite la Vista stato. In tale vista viene visualizzato un elenco di computer e l'avviso con il livello di gravità più elevato. Fare doppio clic su qualsiasi computer per un elenco degli avvisi correnti.
  • È possibile visualizzare gli avvisi tramite la Vista diagramma. In tale vista della gerarchia SMS 2003 viene visualizzata una rappresentazione grafica della gerarchia stessa. A ogni computer è associata un'annotazione sullo stato che ne indica l'avviso con il livello di gravità più elevato. Fare doppio clic su qualsiasi computer per un elenco degli avvisi correnti.

È consigliabile esaminare tutti i nuovi avvisi nell'ordine seguente:

  1. Avvisi sul servizio principale SMS 2003
  2. Avvisi sui servizi dipendenti da SMS 2003
  3. Avvisi basati su SMS 2003 Site System Summarizer
  4. Avvisi sull'integrità del punto di gestione SMS 2003
  5. Avvisi basati sui messaggi di stato di SMS 2003
  6. Avvisi sui componenti di SMS 2003
  7. Avvisi sui backlog di SMS 2003
  8. Avvisi di monitoraggio posta in arrivo SMS 2003
  9. Avvisi sui backup non riusciti dei siti SMS 2003
  10. Avvisi sui programmi con errori di SMS 2003

Verificare l'appartenenza al gruppo di computer

È possibile verificare l'appartenenza al gruppo di computer mediante Operations Manager 2007.

  • Nella console operatore fare clic sul pulsante Creazione e modifica, fare clic su Gruppi e quindi fare clic con il pulsante destro del mouse sul gruppo di computer SMS 2003. Verificare che ognuno dei gruppi di computer visualizzati contenga i computer corretti.

Verificare che gli agenti comunichino con il server Operations Manager 2007

Gli errori di comunicazione tra l'agente e l'infrastruttura di monitoraggio impediscono la ricezione degli avvisi. Verificare che l'agente e il server che esegue Operations Manager 2007 siano in grado di comunicare eseguendo i report Availability. Per ulteriori informazioni, vedere l'argomento relativo alla procedura di creazione di un report Availability in Operations Manager 2007 nella Guida di Operations Manager 2007.

Esaminare i backlog e le frequenze di elaborazione delle prestazioni

I backlog e le frequenze di elaborazione delle prestazioni risultano particolarmente utili per rilevare tendenze quotidiane ed esaminare la gerarchia SMS. È possibile visualizzare i backlog e le frequenze di elaborazione delle prestazioni in Operations Manager 2007.

Per visualizzare i backlog delle prestazioni

Per visualizzare i backlog delle prestazioni, eseguire la procedura seguente:

Per visualizzare i backlog delle prestazioni

  1. Nella console operatore fare clic sul pulsante Monitoraggio e quindi espandere Microsoft Systems Management Server (SMS) 2003.

  2. Espandere Prestazioni e quindi Backlog. Fare quindi clic sulla sottocartella del componente desiderato. Utilizzare l’opzione relativa ai contatori per ridurre i dati visualizzati, il numero dei computer o per selezionare solo i computer di interesse.

Per visualizzare le frequenze di elaborazione delle prestazioni

Per visualizzare le frequenze di elaborazione delle prestazioni, eseguire la procedura seguente:

Per visualizzare le frequenze di elaborazione delle prestazioni

  1. Nella console operatore fare clic sul pulsante Monitoraggio e quindi espandere Microsoft Systems Management Server (SMS) 2003.

  2. Espandere Prestazioni e quindi Backlog. Fare quindi clic sulla sottocartella del componente desiderato. Utilizzare l’opzione relativa ai contatori per ridurre i dati visualizzati, il numero dei computer o per selezionare solo i computer di interesse.

Monitoraggio di SMS 2003 Site Backup

È consigliabile attivare l'attività di manutenzione SMS Site Backup e pianificare i backup in base alle esigenze dell'ambiente aziendale. All'avvio del servizio SMS Site Backup, tutti i servizi SMS vengono arrestati, inclusi SMS_EXECUTIVE, SMS_SQL_MONITOR e SMS_SITE_COMPONENT_MANAGER. Il processo SMS Site Backup non supporta backup in fase di esecuzione delle seguenti operazioni:

  • Copia di parti della cartella di installazione di SMS nel percorso di esportazione di backup.
  • Backup dei diversi valori del Registro di sistema di SMS.
  • Backup del database del sito SMS in un server che esegue Microsoft SQL Server™.

Al termine del backup tutti i servizi SMS vengono riavviati. L'arresto e l'avvio di tali servizi sono eventi normali durante il processo di backup e non indicano la presenza di errori gravi. Gli avvisi previsti in caso di arresto di tali servizi vengono soppressi durante l'esecuzione di SMS Site Backup. È possibile correlare gli arresti e gli avvii dei servizi, nonché quelli del servizio SMS Site Backup. A tale scopo, è necessario attivare le regole seguenti, le quali generano avvisi informativi all'avvio e all'arresto del servizio SMS Site Backup:

  • Interruzione servizio SMS 2003: SMS_SITE_BACKUP
  • Avvio servizio SMS 2003: SMS_SITE_BACKUP

Gli avvisi seguenti vengono generati quando l'avvio del servizio SMS Site Backup non riesce oppure in caso di arresto imprevisto:

  • Errore servizio SMS 2003: SMS_SITE_BACKUP interrotto in modo imprevisto
  • Errore servizio SMS 2003: SMS_SITE_BACKUP bloccato all'avvio
  • Errore servizio SMS 2003: impossibile avviare SMS_SITE_BACKUP
  • Errore servizio SMS 2003: accesso di SMS_SITE_BACKUP non riuscito
  • Errore servizio SMS 2003: SMS_SITE_BACKUP dipende da un altro servizio che non è stato possibile avviare o che non esiste

Se viene visualizzato un avviso indicante che un servizio è stato arrestato in modo imprevisto, verificare che tutti i servizi arrestati siano stati riavviati. È possibile che il servizio SMS Site Backup sia stato terminato prima di riavviarli.

Gli avvisi di messaggio di stato seguenti vengono generati per indicare l'esito positivo o negativo del processo di backup:

  • Stato SMS 2003: backup del sito completato
  • Stato SMS 2003: backup del sito non riuscito

Il backup può avere esito negativo a causa di problemi di accesso, spazio su disco insufficiente, errori di avvio o arresto di determinati servizi o errori nel funzionamento di SQL Server.

Esaminare gli eventi

È consigliabile esaminare gli eventi regolarmente poiché essi indicano errori non gravi e offrono informazioni approfondite sulle modalità di funzionamento dell'agente Operations Manager 2007.

Per esaminare gli eventi

Per esaminare gli eventi, eseguire la procedura seguente:

Per esaminare gli eventi

  1. Nella console operatore fare clic sul pulsante Monitoraggio.

  2. Espandere Microsoft Systems Management Server (SMS) 2003 e quindi fare clic su Eventi.

Vedere anche

Concetti

Attività settimanali per SMS 2003
Attività mensili per SMS 2003
Attività della console di amministrazione SMS 2003

Altre risorse

Esecuzione di attività operative per SMS 2003 Management Pack
Risoluzione dei problemi relativi a SMS 2003 Management Pack
Materiale di riferimento per Microsoft System Management Server 2003 Management Pack


Attività settimanali per SMS 2003

Oltre alle attività di ogni giorno, è consigliabile eseguire le attività seguenti su base settimanale:

  • Analizzare i report. Per un elenco dei report inclusi in SMS 2003 Management Pack, vedere la sezione Report per SMS 2003 nel presente manuale.
  • Analizzare le prestazioni, gli eventi e gli avvisi della settimana precedente per individuare tendenze e problemi potenziali.
  • Se necessario, modificare le impostazioni di configurazione di Operations Manager 2007, ad esempio l'intervallo di heartbeat dell'agente Operations Manager 2007, l'intervallo di controllo dello stato per il monitoraggio dei servizi, l'intervallo di scansione degli heartbeat di Agent Manager, gli intervalli di individuazione e i parametri di pulitura del database.
  • Analizzare la cronologia di backup dei siti SMS.
  • Analizzare la cronologia di backup del gruppo di configurazione di Operations Manager 2007 per SMS 2003.
  • Analizzare il registro e il database di SQL Server.
  • Eseguire i report di disponibilità di SMS 2003 per ottenere la disponibilità dei server SMS e dei relativi componenti.
  • Verificare la gerarchia SMS mediante la vista SMS 2003 Hierarchy Diagram.

Vedere anche

Concetti

Attività quotidiane per SMS 2003
Attività mensili per SMS 2003
Attività della console di amministrazione SMS 2003

Altre risorse

Esecuzione di attività operative per SMS 2003 Management Pack
Risoluzione dei problemi relativi a SMS 2003 Management Pack
Materiale di riferimento per Microsoft System Management Server 2003 Management Pack


Attività mensili per SMS 2003

Oltre alle attività eseguite su base giornaliera e settimanale, è necessario controllare i dati delle categorie seguenti su base mensile.

Avvisi ed eventi più comuni

  • Avvisi più comuni
  • Eventi più comuni
  • Avvisi ed eventi più comuni per gruppo di regole
  • Avvisi ed eventi più comuni per componente di SMS 2003
  • Avvisi ed eventi più comuni per funzionalità di SMS 2003

Sviluppare un piano d'azione per ridurre questi dati.

Monitoraggio dei backlog di SMS

  • Controllare i report relativi alle tendenze dei backlog su vari sistemi del sito.

Tendenze dei backlog di SMS

  • Controllare i report relativi ai backlog per assicurarsi che non esista una tendenza in crescita a lungo termine nel numero di backlog o un livello non accettabile di backlog per i contratti di servizio in un sistema del sito SMS.

Tendenze delle prestazioni di SMS: totali e frequenze di elaborazione

  • Record dei dati di individuazione
  • Inventario hardware
  • Inventario software
  • Controllo software
  • Messaggi di stato

Prestazioni generali del sistema

  • Utilizzo del disco
  • Utilizzo della memoria
  • Utilizzo del processore

Disponibilità dei servizi di SMS

  • SMS_EXECUTIVE
  • Servizio SMS Agent Host
  • Servizio SMS Client
  • SMS_REPORTING_POINT
  • SMS_SERVER_LOCATOR_POINT
  • SMS_SQL_MONITOR
  • SMS_SITE_COMPONENT_MANAGER

Disponibilità di SMS

  • Eseguire i report sulla disponibilità di SMS 2003 per controllare la disponibilità dei server SMS e dei componenti di SMS.

Vedere anche

Concetti

Attività quotidiane per SMS 2003
Attività settimanali per SMS 2003
Attività della console di amministrazione SMS 2003

Altre risorse

Esecuzione di attività operative per SMS 2003 Management Pack
Risoluzione dei problemi relativi a SMS 2003 Management Pack
Materiale di riferimento per Microsoft System Management Server 2003 Management Pack


Attività della console di amministrazione SMS 2003

Per le attività della console di amministrazione SMS è necessario installare la console di amministrazione Microsoft Systems Management Server (SMS) 2003 SP2 o versione successiva nello stesso computer della console operatore Operations Manager 2007. Al termine dell’installazione della console di amministrazione SMS, è necessario disconnettersi e accedere nuovamente a Windows per attivare la funzionalità attività.

Attività di Management Pack

Attività | Descrizione
Console di amministrazione SMS | Apre la console di amministrazione SMS per il computer selezionato. Si applica ai computer che ospitano il ruolo server del sito SMS.
Tutti i messaggi di stato SMS. | Richiede il server del sito del computer, apre una finestra MMC ed esegue una query sui messaggi di stato per restituire tutti i messaggi di stato associati al computer selezionato. Si applica a tutti i sistemi.
SMS Service Manager | Apre l’attività SMS Service Manager per il computer selezionato. Si applica ai computer che ospitano il ruolo server del sito SMS.
Esplora inventario risorse SMS | Richiede il server del sito del computer, apre una finestra MMC in cui Esplora inventario risorse SMS visualizza i dati per il computer selezionato. Si applica a tutti i sistemi.

Vedere anche

Concetti

Attività quotidiane per SMS 2003
Attività settimanali per SMS 2003
Attività mensili per SMS 2003

Altre risorse

Esecuzione di attività operative per SMS 2003 Management Pack
Risoluzione dei problemi relativi a SMS 2003 Management Pack
Materiale di riferimento per Microsoft System Management Server 2003 Management Pack


Risoluzione dei problemi relativi a SMS 2003 Management Pack

Per risolvere i problemi relativi al prodotto, è possibile eseguire le azioni seguenti.

  • Controllare che Operations Manager 2007 sia stato installato correttamente.
  • Controllare che le impostazioni di configurazione di Operations Manager 2007 siano corrette.
  • Controllare che tutti i sistemi Microsoft® Systems Management Server (SMS) siano stati configurati con le informazioni di Operations Manager.
  • Controllare che in tutti i computer gestiti con provider SMS e database di sito SMS sia stato installato l'agente Microsoft Operations Manager 2007 e che tali computer siano stati attivati per fungere da proxy per altri computer.
  • Verificare che l'importazione del Management Pack sia stata completata senza errori.
  • Controllare che tutte le entità significative siano attivate, ad esempio le regole e gli avvisi associati.
  • Controllare che i gruppi di computer contengano i computer corretti. Per eseguire questo controllo, è possibile utilizzare le visualizzazioni.
  • Controllare che non siano presenti avvisi di errori di heartbeat.
  • Controllare che l'intervallo di heartbeat sia impostato correttamente e che le regole vengano propagate nel computer con l'agente Microsoft Operations Manager 2007.
  • Controllare che i servizi dipendenti, inclusi Strumentazione gestione Windows (WMI), il servizio Pubblicazione sul Web, il servizio di amministrazione di Internet Information Services (IIS), il servizio di trasferimento intelligente in background e Microsoft SQL Server, siano installati e funzionino correttamente nei sistemi del sito SMS 2003.
  • Controllare che non siano presenti regole disattivate automaticamente da Operations Manager 2007 a causa di un'eccessiva esecuzione, sintassi errata o durata eccessiva degli script.
  • Controllare che tutti i contatori delle prestazioni siano stati installati correttamente.

In questa sezione

Problemi noti di SMS 2003

Vedere anche

Concetti

Scenari di monitoraggio del Management Pack
Distribuzione di SMS 2003 Management Pack

Altre risorse

Panoramica di System Management Server 2003 Management Pack
Esecuzione di attività operative per SMS 2003 Management Pack
Materiale di riferimento per Microsoft System Management Server 2003 Management Pack


Problemi noti di SMS 2003

Di seguito sono riportati i problemi noti di Systems Management Server 2003 Management Pack per Operations Manager 2007.

La vista della topologia e la modalità manutenzione richiedono SMS 2003 SP3

SMS potrebbe interferire con l'installazione di software non Microsoft che interrompe il servizio WMI

Monitoraggio WMI

Le attività SMS vengono eseguite solo nel contesto utente utilizzato per installare la console di amministrazione SMS 2003

SMS 2003 Management Pack non è in grado di rilevare un sito secondario SMS se la console di amministrazione SMS è installata sullo stesso computer

Riavvio del sistema

Script Monitoraggio messaggi di stato SMS 2003

Lo script Monitoraggio Site System Summarizer in SMS 2003 ha uno scarto rispetto all'intervallo predefinito di Site System Status Summarizer

Le regole messaggi di stato che controllano la connettività del server Sender dipendono dal funzionamento del server Sender

Il monitoraggio BITS è disattivato per impostazione predefinita

Il percorso del provider del registro applicazioni è impostato su C:\SMS\Logs per impostazione predefinita, ma tale percorso potrebbe non essere sempre valido su tutti i server del sito SMS

La vista della topologia e la modalità manutenzione richiedono SMS 2003 SP3

SMS 2003 SP3 è necessario sui server del sito SMS 2003 per attivare la modalità manutenzione o visualizzare la topologia del sito con Operations Manager 2007. Per ulteriori informazioni, vedere Configurazione di SMS supportata.

SMS potrebbe interferire con l'installazione di software non Microsoft che interrompe il servizio WMI

SMS 2003 Management Pack potrebbe interferire con l'installazione di software non Microsoft che accede al servizio WMI. La maggior parte degli script di Management Pack utilizza WMI per accedere al Registro di sistema ed è in grado di riavviare il servizio WMI. Se il servizio WMI è attivato e può essere avviato, COM sarà in grado di riavviare WMI.

Se il software non Microsoft si interrompe ma non disattiva WMI durante un’installazione o un aggiornamento, il riavvio automatico dello script WMI potrebbe influire sul completamento dell’installazione del software non Microsoft. Ciò potrebbe rappresentare un problema per gli aggiornamenti WMI o del provider WMI se il programma di installazione non disattiva innanzitutto il servizio WMI. Ciò vale per qualsiasi client di WMI.

Monitoraggio WMI

  • Le regole seguenti basate sugli eventi di sistema Windows NT® registrano gli eventi da Gestione controllo servizi per gli errori del servizio imprevisti. Non ci sono limitazioni del sistema operativo note per queste regole.
  • Errore del servizio dipendente SMS 2003: Strumentazione gestione Windows interrotto in modo imprevisto.
  • Errore del servizio dipendente SMS 2003: Strumentazione gestione Windows bloccato all'avvio.
  • Errore del servizio dipendente SMS 2003: impossibile avviare Strumentazione gestione Windows.
  • Errore del servizio dipendente SMS 2003: accesso di Strumentazione gestione Windows non riuscito.
  • Errore del servizio dipendente SMS 2003: Strumentazione gestione Windows dipende da un altro servizio che non è stato possibile avviare o non esiste.

Le attività SMS vengono eseguite solo nel contesto utente utilizzato per installare la console di amministrazione SMS 2003

Questo problema può verificarsi perché la variabile di ambiente SMS_UI_PATH è stata creata dall’installazione della console di amministrazione SMS come variabile di ambiente utente, non come variabile di ambiente di sistema. Per risolvere questo problema, è possibile copiare il nome e il valore di SMS_UI_PATH e definire le variabili sopra indicate come variabili di ambiente di sistema, in modo tale che tutti gli operatori e gli amministratori possano richiamare le attività senza errori.

Systems Management Server 2003 Management Pack non è in grado di rilevare un sito secondario SMS se la console di amministrazione SMS è installata sullo stesso computer

Se si installa una console di amministrazione Systems Management Server 2003 in un computer che è anche un server di sito secondario SMS, SMS 2003 Management Pack non è in grado di identificare il server come server di sito secondario SMS.

Per risolvere il problema, quando si installa la console di amministrazione SMS in un server di sito secondario SMS, è necessario modificare il valore del Registro di sistema HKLM\SOFTWARE\Microsoft\SMS\Setup\Type passando da 4 a 2.

Riavvio del sistema

In caso di riavvio del sistema, è possibile che si ricevano solo alcuni avvisi di interruzione del servizio. Non ci sono eventi o avvisi che indicano che il sistema è stato riavviato. Il modo migliore per rilevare un arresto del sistema previsto o imprevisto consiste nell'installare Microsoft Windows Servers Base Operating System Management Pack, che contiene una regola che avvisa l’utente in caso di riavvio del sistema. Per determinare se il sistema è stato riavviato è inoltre possibile controllare i registri SMS, il registro degli eventi NT di Operations Manager 2007, i registri degli eventi di Windows NT e gli eventi di Operations Manager 2007 per la comunicazione con l'agente.

Script Monitoraggio messaggi di stato SMS 2003

Quando la tabella dei messaggi di stato di SMS supera 4.294.967.296 messaggi, la numerazione dell'ID record ricomincia da zero. Lo script Monitoraggio messaggi di stato SMS 2003 non dispone di un meccanismo per rilevare quando si ricomincia da zero per l'assegnazione degli ID record. Attualmente lo script parte dall’ID record dell’ultimo messaggio di stato elaborato. Se l’ID record ricomincia da zero, Management Pack non è in grado di rilevare i nuovi messaggi di stato.

Sul lato server, si noti il valore di Next Status Message Record ID nella chiave del Registro di sistema HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER. Questo è l'ID record successivo che si trova nella tabella dei messaggi di stato di SQL. Se questo valore è inferiore al valore LastRecordID, la tabella dei messaggi di stato è ricominciata da zero. Lo script non elabora nuovamente i messaggi fino a quando il valore del Registro di sistema Next Status Message Record ID non è maggiore del valore LastRecordID nel file VarSet.

È consigliabile monitorare periodicamente la chiave del Registro di sistema HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER sul lato server per l'ID record del messaggio di stato successivo. Per le piccole imprese o i siti di piccole dimensioni che si trovano a un livello basso nella gerarchia SMS, è consigliabile controllare questa chiave del Registro di sistema ogni due o tre mesi. Per le grandi imprese o i siti con parecchi siti figlio è consigliabile controllare questa chiave del Registro di sistema ogni mese. Se il valore si avvicina a 4.294.967.296, controllarlo più di frequente. Dopo che l'ID record è stato reimpostato su zero, è necessario sbloccare il monitoraggio dei messaggi di stato nel computer che esegue il server di database del sito SMS per il sito. Il percorso del database del sito SMS viene designato durante l'installazione di SMS.

Per automatizzare il monitoraggio della chiave del Registro di sistema è possibile creare un attributo di computer e un gruppo di computer per controllare i computer che si stanno avvicinando a questa soglia.

Per individuare tutti i database di sito SMS nel gruppo di configurazione

  1. Nella console operatore fare clic sul pulsante Creazione e modifica.
  2. Nel riquadro dei risultati fare clic con il pulsante destro del mouse su Microsoft Systems Management Server (SMS) 2003 e quindi scegliere Visualizza membri del gruppo.

Per sbloccare il monitoraggio dei messaggi di stato

  1. Nella cartella temporanea di Windows sul computer che ospita il ruolo database di sito SMS aprire il file di testo seguente: SMS 2003 Monitor SMS Status Messages.VarSet. La voce LastRecordID_[SMSDatabaseName] è un valore di ID record che indica l'ultimo messaggio di stato nella tabella dei messaggi di stato di SQL elaborata dallo script.
  2. Sul computer che ospita il ruolo database di sito SMS modificare il valore LastRecordID_[SMSDatabaseName] per il sito appropriato nel file denominato SMS 2003 Monitor SMS Status Messages.VarSet in modo che corrisponda al valore del Registro di sistema Next Status Message Record ID meno uno. Se il risultato è 4.294.967.296, impostare il valore su zero e salvare il file.

Lo script Monitoraggio Site System Summarizer in SMS 2003 ha uno scarto rispetto all'intervallo predefinito di Site System Status Summarizer

Lo script Monitor Site System Summarizer di SMS 2003 viene eseguito con uno scarto di 10 minuti rispetto al polling del generatore riepilogo dello stato del sistema del sito, per cui è impostato un intervallo di 60 minuti con decorrenza dall'ora esatta. Sebbene la console di amministrazione SMS consenta di configurare la pianificazione del generatore riepilogo dello stato del sistema del sito, essa non modifica tuttavia questo intervallo di polling, ma solo l’intervallo per altre attività di manutenzione. Lo script Monitor Site System Summarizer in SMS 2003 viene eseguito mediante un provider di eventi temporizzato, Schedule Every 60 Minutes Synchronize at 00:10. Lo scarto di 10 minuti concede al generatore riepilogo dello stato del sistema del sito il tempo necessario per completare il ciclo. Se questo periodo di tempo è insufficiente, è necessario estenderlo, altrimenti lo script terminerà prima che il generatore riepilogo dello stato del sistema del sito abbia completato il ciclo. Di conseguenza, lo stato del sistema del sito visualizzato potrebbe essere non aggiornato.

Le regole messaggi di stato che controllano la connettività del server Sender dipendono dal funzionamento del server Sender

Se il server Sender non è in grado di connettersi al sito padre, i messaggi di stato non vengono trasmessi attraverso la gerarchia SMS e Management Pack non genera un avviso relativo a tali messaggi di stato. Ciò è particolarmente importante nel caso di siti secondari per cui non è in esecuzione lo script Monitoraggio messaggi di stato di SMS 2003. Le regole messaggi di stato seguenti che controllano la connettività del server Sender dipendono dal funzionamento del Sender e sono disattivate per impostazione predefinita:

  • Stato SMS 2003: il Sender non è in grado di connettersi al sito remoto tramite la LAN (protezione standard).
  • Stato SMS 2003: il Sender non è in grado di connettersi al sito remoto tramite connessione RAS.
  • Stato SMS 2003: il Sender non è in grado di connettersi al sito remoto tramite la LAN (protezione avanzata).
Nota
Tutte queste regole sono disattivate per impostazione predefinita. Affinché queste regole possano funzionare, è necessario che ogni server di database del sito SMS, o almeno il sito centrale, sia un computer gestito.

È stato implementato un metodo di monitoraggio parallelo basato su un provider del registro applicazioni, il registro del server Sender SMS 2003. Queste regole sono attivate per impostazione predefinita. Se queste regole vengono disattivate, è consigliabile considerare l'attivazione delle regole messaggi di stato complementari sopra indicate. Non attivare entrambi i set di regole, perché verranno generati avvisi duplicati. Non esiste un consolidamento di questi eventi o di queste regole avvisi in grado di fare riferimento sia alla regola componenti che alla regola messaggi di stato attiva.

  • Componente SMS 2003: il Sender non è in grado di connettersi al sito remoto tramite la LAN (protezione standard).
  • Componente SMS 2003: il Sender non è in grado di connettersi al sito remoto tramite connessione RAS.
  • Componente SMS 2003: il Sender non è in grado di connettersi al sito remoto tramite la LAN (protezione avanzata).

Affinché queste regole possano funzionare, è necessario modificarle in modo che rimandino ai file di registro SMS. È inoltre necessario che ogni server SMS con un server Sender sia un computer gestito.

Il monitoraggio BITS è disattivato per impostazione predefinita

Poiché il servizio di trasferimento intelligente in background BITS viene avviato su richiesta del client avanzato di SMS, la regola seguente è disattivata per impostazione predefinita in SMS 2003 Management Pack:

  • Servizio dipendente SMS 2003 in esecuzione: BITS (servizio trasferimento intelligente in background)

Se il servizio è configurato per l'avvio automatico, è consigliabile attivare questa regola.

Le regole seguenti sono attivate per impostazione predefinita per poter controllare i problemi con il servizio BITS e poter segnalare se l'host agenti di SMS non è in grado di avviare il servizio BITS quando richiesto:

  • Errore del servizio SMS 2003: servizio BITS (servizio trasferimento intelligente in background) interrotto in modo imprevisto.
  • Errore del servizio SMS 2003: servizio BITS (servizio trasferimento intelligente in background) bloccato all'avvio.
  • Errore del servizio SMS 2003: impossibile avviare il servizio BITS (servizio trasferimento intelligente in background).
  • Errore del servizio SMS 2003: accesso del servizio BITS (servizio trasferimento intelligente in background) non riuscito.

Errore del servizio SMS 2003: il servizio BITS (servizio trasferimento intelligente in background) dipende da un altro servizio che non è stato possibile avviare o che non esiste.

Il percorso del provider del registro applicazioni è impostato su C:\SMS\Logs per impostazione predefinita, ma tale percorso potrebbe non essere sempre valido su tutti i server del sito SMS

Ci sono quattro regole componenti che utilizzano il provider del registro applicazioni per monitorare i file di registro SMS in C:\SMS\Logs:

  • Componente SMS 2003: il Sender non è in grado di connettersi al sito remoto tramite la LAN (protezione standard).
  • Componente SMS 2003: il Sender non è in grado di connettersi al sito remoto tramite connessione RAS.
  • Componente SMS 2003: il Sender non è in grado di connettersi al sito remoto tramite la LAN (protezione avanzata).
  • Componente SMS 2003: Distribution Manager non è in grado di elaborare un pacchetto.

Le regole del Sender sono attivate per impostazione predefinita mentre la regola di Distribution Manager è disattivata per impostazione predefinita. Se SMS è stato installato su un'unità diversa dall'unità C o se la cartella predefinita per l'archiviazione dei registri è stata modificata, è necessario modificare questa regola prima di attivarla. Se la regola non viene modificata in modo da eseguire la ricerca dei file di registro nella cartella appropriata, l'avviso non restituisce le informazioni cercate.

Quando si modifica la regola per designare il percorso corretto, è possibile digitare un percorso per i file di registro o creare una variabile di ambiente e modificare la regola in modo che venga utilizzata tale variabile. Se si digita un percorso, deve essere valido su tutti i server del sito su cui ha effetto questa regola. Se si hanno due percorsi diversi, uno per i server del sito primario e uno per i server del sito secondario, eseguire la procedura seguente:

Per modificare le regole componenti in formato XML per utilizzare un percorso alternativo per i file di registro

  1. Nella console operatore Operations Manager 2007 fare clic sul pulsante Creazione e modifica, espandere Oggetti Management Pack e quindi fare clic su Regole.

  2. Nel riquadro Dettagli fare clic con il pulsante destro del mouse sulla regola che si desidera modificare e quindi scegliere Proprietà.

  3. Fare clic sulla scheda Configurazione.

  4. Nel riquadro Risposte selezionare la risposta di cui si desidera modificare il file XML.

  5. Fare clic sul pulsante Modifica. Verrà visualizzata la finestra di dialogo Genera avviso - Proprietà.

  6. Nella scheda Configurazione della finestra di dialogo Genera avviso - Proprietà fare clic sul pulsante Modifica.

  7. Modificare la stringa di directory nel modo desiderato. Fare clic su OK, quindi su Applica e infine su OK per salvare la modifica.

Vedere anche

Concetti

Configurazione di SMS supportata

Altre risorse

Risoluzione dei problemi relativi a SMS 2003 Management Pack
Panoramica di System Management Server 2003 Management Pack
Materiale di riferimento per Microsoft System Management Server 2003 Management Pack


Materiale di riferimento per Microsoft System Management Server 2003 Management Pack

Il presente materiale di riferimento include informazioni su Operations Manager 2007 e System Management Server 2003

In questa sezione

Ulteriori risorse relative a Microsoft System Management Server 2003 Management Pack

Siti e componenti per SMS 2003 Management Pack

Gruppi di computer per SMS 2003

Gruppo di regole per SMS 2003

Provider per SMS 2003

Script per SMS 2003

Viste per Microsoft SMS 2003

Diagrammi per SMS 2003

Report per SMS 2003

Vedere anche

Concetti

Scenari di monitoraggio del Management Pack
Distribuzione di SMS 2003 Management Pack

Altre risorse

Panoramica di System Management Server 2003 Management Pack
Esecuzione di attività operative per SMS 2003 Management Pack
Risoluzione dei problemi relativi a SMS 2003 Management Pack


Ulteriori risorse relative a Microsoft System Management Server 2003 Management Pack

Sono disponibili le risorse seguenti relative a Microsoft System Management Server 2003 Management Pack.

Microsoft Operations Manager 2007

Per accedere alla documentazione principale di Operations Manager 2007 disponibile su Internet e per ottenere le informazioni più recenti su System Center Operations Manager 2007, visitare la pagina Web relativa a Operations Manager 2007 all'indirizzo http://go.microsoft.com/fwlink/?LinkID=83259.

SMS 2003

Tutte le informazioni necessarie per distribuire e utilizzare SMS 2003 sono disponibili nella documentazione principale del prodotto, nella Guida della console di amministrazione SMS, nel glossario SMS e nella documentazione SMS Online Library. SMS Online Library e la Guida della console di amministrazione SMS sono accessibili dalla console stessa.

SMS 2003 Online Library

Nella documentazione SMS Online Library sono disponibili riferimenti a tutte le informazioni necessarie per distribuire e utilizzare SMS. Dopo l'installazione di SMS 2003, è possibile eseguire SMS Online Library in due modi:

  • Fare clic sul pulsante Start, scegliere Programmi, Systems Management Server e quindi SMS Online Library.
  • Fare clic con il pulsante destro del mouse su SMS Online Library nell'albero della console di amministrazione SMS e quindi scegliere Run Online Library.

Online Library include i contenuti seguenti:

  • Le note sulla versione di SMS 2003, contenenti informazioni importanti su SMS.
  • Una sezione relativa alle novità della versione corrente di SMS nel quale vengono descritte le differenze tra SMS 2003 e le versioni precedenti.
  • Un collegamento alla pagina Web della documentazione di SMS.
  • Collegamenti alle pagine per il download di SMS 2003 Device Management Feature Pack e SMS 2003 Operating System Deployment Feature Pack.

SMS sul Web

  • Per trovare articoli tecnici e informazioni sui prodotti correlati, visitare il sito Web relativo a Microsoft Systems Management Server 2003. Nel sito Web dedicato a SMS sono inoltre disponibili informazioni specifiche su come utilizzare SMS con altri prodotti Microsoft, ad esempio Microsoft Windows® XP e Microsoft Office XP.
  • Per i collegamenti alle versioni consultabili e scaricabili della documentazione principale di SMS 2003, visitare la pagina Web della documentazione di Systems Management Server 2003.
  • Microsoft gestisce numerosi newsgroup gratuiti in cui è possibile inviare domande e ottenere supporto da altri utenti, nonché spesso da membri del team del prodotto SMS. Per ulteriori informazioni sui newsgroup gratuiti, visitare la pagina Web della community di Systems Management Server.
  • Per articoli tecnici sulle procedure, domande frequenti, webcast, newsgroup e altro, visitare la pagina Web del supporto tecnico per Systems Management Server.
  • Per trovare rapidamente risposte accurate a domande relative a SMS eseguendo ricerche nella Microsoft Knowledge Base e in altre risorse tecniche, visitare il sito Web Guida in linea e supporto tecnico Microsoft. È possibile eseguire ricerche nella Knowledge Base per trovare articoli relativi a problemi specifici mediante il numero "Qxxxxxx" oppure il numero "xxxxxxx" assegnato al problema.

Commenti e suggerimenti degli utenti

  • È possibile inviare commenti e suggerimenti che consentano al team della documentazione di SMS di offrire le informazioni sul prodotto di maggiore interesse per gli utenti. È possibile inviare commenti e suggerimenti sulla documentazione a SMS Documentation.

Vedere anche

Concetti

Siti e componenti per SMS 2003 Management Pack
Gruppi di computer per SMS 2003
Gruppo di regole per SMS 2003
Provider per SMS 2003
Script per SMS 2003
Viste per Microsoft SMS 2003
Diagrammi per SMS 2003
Report per SMS 2003


Siti e componenti per SMS 2003 Management Pack

I componenti di SMS 2003 includono il server del sito centrale SMS, il database di sito SMS e la console di amministrazione SMS. In genere il server del sito centrale SMS, il database di sito SMS e la console di amministrazione SMS risiedono nello stesso server e ogni ruolo del sistema del sito risiede in un server dedicato. Insieme agli eventuali ruoli del sistema del sito, il database e il server del sito centrale costituiscono un singolo sito SMS, che può includere più ruoli del sistema del sito duplicati. Un singolo sito può ad esempio includere più punti di accesso client. I siti SMS 2003 possono avere più livelli. Un sito SMS può non includere alcuni ruoli del server del sito, ad esempio un punto di localizzazione del server.

SMS 2003 Management Pack è progettato per monitorare i componenti del server SMS, ma non le funzionalità di SMS su computer client SMS. È tuttavia possibile utilizzare Operations Manager 2007 per monitorare altre applicazioni che risiedono in un computer client SMS.

Per ulteriori informazioni sui componenti di SMS 2003, vedere la documentazione SMS 2003 Online Library. Per collegamenti relativi alla documentazione di SMS 2003, vedere la sezione Ulteriori risorse relative a Microsoft System Management Server 2003 Management Pack in questo manuale.

I componenti e i ruoli del server principali includono:

  • Punto di accesso client
  • Punto di distribuzione
  • Punto di gestione
  • Punto di localizzazione del server
  • Punto di reporting
  • Server del sito
  • Database di sito
  • Server Sender
  • Client avanzato
  • Client precedente
  • Provider SMS
  • Console di amministrazione SMS

Punto di accesso client

Questo ruolo è il punto di contatto tra i client precedenti e il server del sito SMS. Il punto di accesso client passa tutti i dati dei client precedenti al server del sito. I computer client precedenti contattano il punto di accesso client per ottenere informazioni di gestione dal server del sito SMS. Un punto di accesso client serve un solo sito SMS ed è installato per impostazione predefinita nel server del sito. Il punto di accesso client:

  • Offre file e istruzioni di configurazione specifici per il client precedente durante l'installazione del client e l'esecuzione di modifiche dopo l'installazione.
  • Funge da fonte di annunci per i computer client precedenti.
  • Riceve i dati dai client precedenti e li inoltra al server del sito SMS. Ad esempio, quando un client ha eseguito un inventario software o hardware e creato un file di dati dell'inventario, invia questi dati al punto di accesso client. Tutti i messaggi di stato provenienti dal client vengono replicati nel punto di accesso client.

Punto di distribuzione

Il punto di distribuzione archivia i file origine pacchetto SMS che i client SMS utilizzano durante l'installazione di programmi software distribuiti da SMS. Quando l'amministratore di SMS annuncia un programma, l'annuncio e le informazioni sul programma sono disponibili per i client attraverso un punto di accesso client per client precedenti o un punto di gestione per client avanzati.

Quando SMS è configurato, al server del sito viene automaticamente assegnato il ruolo punto di distribuzione. L'amministratore di SMS può attivare l'utilizzo del servizio BITS (Servizio trasferimento intelligente in background) da parte del punto di distribuzione per consentire il download del file del pacchetto incrementale nei client avanzati.

I client avanzati utilizzano il servizio BITS (Servizio trasferimento intelligente in background) per individuare automaticamente la capacità di connessione di rete dei client e regolare in modo efficace le velocità di trasferimento. Ciò è supportato solo su client che eseguono i sistemi operativi Microsoft Windows 2000, Microsoft Windows XP Professional e Microsoft Windows Server™ 2003.

Punto di gestione

Il punto di gestione è il punto principale di contatto tra i client avanzati e il server del sito SMS. Un sito SMS ha un solo punto di gestione predefinito, ma è possibile configurare più punti di gestione con il servizio Bilanciamento carico di rete di Windows. Analogamente alla relazione tra i punti di accesso client e i client precedenti, un punto di gestione:

  • Offre dettagli specifici di configurazione client (noti anche come criteri client avanzato) per il client avanzato dopo l'installazione del client.
  • Funge da fonte di annunci per i computer client avanzati.
  • Individua i punti di distribuzione per i client avanzati.
  • Riceve le informazioni relative a stato, inventari e controllo software dai client avanzati e le inoltra al server del sito SMS.

Punto di localizzazione del server

Il punto di localizzazione del server individua i punti di accesso client per i client precedenti e i punti di gestione per i client avanzati. Questo punto viene utilizzato principalmente durante l'installazione dei client. Il punto di localizzazione del server:

  • Individua un punto di gestione per il client avanzato se quest'ultimo è configurato per l'assegnazione automatica del sito SMS.
  • Offre ai client avanzati la posizione del punto di gestione durante l'installazione del client avviata dallo script di accesso e durante un'installazione senza credenziali sufficienti.
  • Garantisce l'assegnazione del sito SMS per il client precedente e individua i punti di accesso client durante l'installazione del client avviata dallo script di accesso.

Punto di reporting

Un punto di reporting è un server che esegue il servizio IIS (Internet Information Services) e contiene il codice per il visualizzatore di report e report supplementari. Un punto di reporting comunica solo con il proprio server di database del sito SMS.

Client avanzato

SMS 2003 soddisfa le esigenze di elaborazione mobile attraverso il client avanzato. Il client avanzato supporta l'intero set di funzionalità SMS, incluse la distribuzione del software, la gestione delle risorse e la risoluzione dei problemi remota. È possibile gestire utenti mobili e utenti desktop senza fare alcuna distinzione tra di loro. Il client avanzato utilizza una tecnologia Windows denominata BITS (Servizio trasferimento intelligente in background) per garantire la connettività per tutte le operazioni di gestione.

Client precedente

È possibile utilizzare il client precedente se l'organizzazione deve gestire computer che non soddisfano i requisiti necessari per il supporto del client avanzato. È possibile attivare, configurare e controllare i metodi di installazione del client precedente seguenti:

  • Installazione del client avviata dallo script di accesso
  • Installazione push del client
  • Installazione manuale del client

Provider SMS

Il provider SMS elabora le richieste di dati provenienti dal database di sito SMS. Il ruolo provider SMS viene installato nello stesso computer del server del sito SMS o del database di sito SMS. È consigliabile installare il provider SMS e il database di sito SMS nello stesso server del sito. Il provider SMS garantisce l'accesso ai dati per la console di amministrazione SMS installata nel sito.

Console di amministrazione SMS

La console di amministrazione SMS è l'interfaccia grafica utilizzata per l'amministrazione di SMS. Questa interfaccia utilizza uno snap-in MMC (Microsoft Management Console) incluso nel software SMS. Per impostazione predefinita, la console viene installata quando si installa un server del sito primario. Può inoltre essere installata in altri server o workstation.

Vedere anche

Concetti

Ulteriori risorse relative a Microsoft System Management Server 2003 Management Pack
Siti e componenti per SMS 2003 Management Pack
Gruppi di computer per SMS 2003
Gruppo di regole per SMS 2003
Provider per SMS 2003
Script per SMS 2003
Viste per Microsoft SMS 2003
Diagrammi per SMS 2003
Report per SMS 2003


Gruppi di computer per SMS 2003

SMS 2003 Management Pack offre i gruppi di computer seguenti:

  • Microsoft SMS 2003 Administrator Consoles
  • Microsoft SMS 2003 Advanced Clients
  • Microsoft SMS 2003 Central Site Servers
  • Microsoft SMS 2003 Clients
  • Microsoft SMS 2003 Client Access Point Servers
  • Microsoft SMS 2003 Component Servers Based on IIS
  • Microsoft SMS 2003 Component Servers Based on SMS Executive
  • Microsoft SMS 2003 Distribution Point Servers
  • Microsoft SMS 2003 Management Point Servers
  • Microsoft SMS 2003 Primary Site Servers
  • Microsoft SMS 2003 Providers
  • Microsoft SMS 2003 Reporting Point Servers
  • Microsoft SMS 2003 Secondary Site Servers
  • Microsoft SMS 2003 Sender Servers
  • Microsoft SMS 2003 Server Locator Point Servers
  • Microsoft SMS 2003 Servers
  • Microsoft SMS 2003 Site Servers
  • Microsoft SMS 2003 Legacy Clients

Vedere anche

Concetti

Ulteriori risorse relative a Microsoft System Management Server 2003 Management Pack
Siti e componenti per SMS 2003 Management Pack
Gruppi di computer per SMS 2003
Gruppo di regole per SMS 2003
Provider per SMS 2003
Script per SMS 2003
Viste per Microsoft SMS 2003
Diagrammi per SMS 2003
Report per SMS 2003


Gruppo di regole per SMS 2003

In questa sezione vengono elencati i gruppi di regole e le regole degli eventi di Systems Management Server (SMS) 2003 Management Pack che generano avvisi ed eventi critici. Per analizzare tutte le regole del gruppo di regole, vedere Creazione e modifica nella console operatore Operations Manager 2007.

SMS Clients - Advanced

Il gruppo SMS Clients - Advanced contiene regole per errori relativi ai client avanzati di SMS.

  • SMS 2003 service running: SMS Agent Host
  • SMS 2003 dependent service running: Background Intelligent Transfer Service
  • SMS 2003 dependent service running: Windows Management Instrumentation

SMS Client Access Points

Il gruppo SMS Clients Access Points contiene regole per errori relativi ai punti di accesso client SMS.

  • SMS 2003 service running: SMS_EXECUTIVE

SMS Management Points

Il gruppo SMS Management Points contiene regole per errori relativi ai punti di gestione SMS.

  • SMS 2003 service running: SMS Agent Host
  • SMS 2003 service running: SMS_EXECUTIVE
  • SMS 2003 dependent service running: World Wide Web Publishing Service
  • SMS 2003 dependent service running: IIS Admin Service
  • SMS 2003 Management Point Health: State
  • SMS 2003 Perf Threshold: MP DDR Backlog > 10,000 over 3 hours
  • SMS 2003 Perf Threshold: MP HINV Backlog > 10,000 over 3 hours
  • SMS 2003 Perf Threshold: MP SINV Backlog > 10,000 over 3 hours
  • SMS 2003 Perf Threshold: MP FileCollection Backlog > 10,000 over 3 hours
  • SMS 2003 Perf Threshold: MP Relay Mgr Backlog > 10,000 over 3 hours
  • SMS 2003 Perf Threshold: MP Status Backlog > 10,000 over 3 hours
  • SMS 2003 Perf Threshold: Process - % Processor time (ccmexec) > 95 over 3 hours

SMS Providers

Il gruppo SMS Providers contiene regole per errori relativi al componente Provider SMS di SMS 2003.

  • SMS 2003 dependent service running: Windows Management Instrumentation

SMS Reporting Points

Il gruppo SMS Reporting Points contiene regole per errori relativi ai punti di reporting SMS.

  • SMS 2003 service running: SMS_REPORTING_POINT
  • SMS 2003 dependent service running: World Wide Web Publishing Service
  • SMS 2003 dependent service running: IIS Admin Service

SMS Sender Servers

Il gruppo SMS Sender Servers contiene regole per errori relativi ai server Sender SMS.

  • SMS 2003 service running: SMS_EXECUTIVE

SMS Server Locator Points

Il gruppo SMS Server Locator Points contiene regole per errori relativi ai punti di localizzazione del server SMS.

  • SMS 2003 dependent service running: World Wide Web Publishing Service
  • SMS 2003 dependent service running: IIS Admin Service
  • SMS 2003 service running: SMS_SERVER_LOCATOR_POINT

SMS Server - Common

Il gruppo SMS Server - Common contiene regole per errori relativi a tutti i server SMS.

  • SMS 2003 Perf Threshold: Paging File - %Usage > 98 over 3 hours
  • SMS 2003 Perf Threshold: Processor - % Processor time (_Total) > 95 over 3 hours

SMS Servers Based on SMS Executive

Il gruppo SMS Servers Based on SMS Executive contiene regole per errori generati su qualsiasi server del sito che esegue il servizio SMS Executive.

  • SMS 2003 Perf Threshold: Process - % Processor time (smsexec) > 95 over 3 hours

SMS Site Database Servers

Il gruppo SMS Site Database Servers contiene regole per errori relativi al server di database del sito SMS.

  • SMS 2003 service running: SMS_SQL_MONITOR
  • SMS 2003 dependent service running: MSSQLSERVER
  • SMS 2003 Perf Threshold: SMS SQL Connections > 500 over 2 hours

SMS Site Servers - Common

Il gruppo SMS Site Servers - Common contiene regole per errori relativi a tutti i server del sito SMS.

  • SMS 2003 service running: SMS_SITE_COMPONENT_MANAGER
  • SMS 2003 service running: SMS_EXECUTIVE
  • SMS 2003 Perf Threshold: Site Server Scheduler Jobs Backlog > 10,000 over 3 hours
  • SMS 2003 Perf Threshold: Site Server Scheduler Send Requests Backlog > 10,000 over 3 hours
  • SMS 2003 Perf Threshold: Site Server SWM Backlog > 10,000 over 3 hours
  • SMS 2003 Perf Threshold: Site Server SINV Backlog > 10,000 over 3 hours
  • SMS 2003 Perf Threshold: Site Server HINV Backlog > 10,000 over 3 hours
  • SMS 2003 Perf Threshold: Site Server DDR Backlog > 10,000 over 3 hours

SMS Site Database Servers - Primary

Il gruppo SMS Site Servers - Primary contiene regole per errori relativi a tutti i server del sito primario SMS.

  • SMS 2003 Perf Threshold: Site Server SINV Backlog > 10,000 over 3 hours
  • SMS 2003 Perf Threshold: Site Server HINV Backlog > 10,000 over 3 hours

Vedere anche

Concetti

Ulteriori risorse relative a Microsoft System Management Server 2003 Management Pack
Siti e componenti per SMS 2003 Management Pack
Gruppi di computer per SMS 2003
Gruppo di regole per SMS 2003
Provider per SMS 2003
Script per SMS 2003
Viste per Microsoft SMS 2003
Diagrammi per SMS 2003
Report per SMS 2003


Provider per SMS 2003

I tipi di provider di dati utilizzati da SMS 2003 Management Pack sono i seguenti:

  • Registro applicazioni
  • Evento temporizzato
  • Contatore delle prestazioni di Windows NT

Vedere anche

Concetti

Ulteriori risorse relative a Microsoft System Management Server 2003 Management Pack
Siti e componenti per SMS 2003 Management Pack
Gruppi di computer per SMS 2003
Gruppo di regole per SMS 2003
Script per SMS 2003
Viste per Microsoft SMS 2003
Diagrammi per SMS 2003
Report per SMS 2003


Script per SMS 2003

SMS 2003 Management Pack include script di Operations Manager 2007 eseguiti automaticamente nell'agente e script che devono essere eseguiti da un amministratore. In questa sezione sono disponibili informazioni aggiuntive su alcuni di questi script.

Gli script seguenti vengono eseguiti automaticamente dall'agente di Operations Manager 2007:

  • SMS 2003 Monitor SMS Status Messages
  • SMS 2003 Monitor Site System Summarizer
  • SMS 2003 Service Discovery – Client
  • SMS 2003 Service Discovery – Server
  • SMS 2003 Site Backup Event Suppression
  • SMS 2003 Monitor Management Point Health
  • SMS 2003: Monitor Management Point Availability
  • Individuazione gerarchia dei siti SMS 2003
  • SMS 2003 Monitor SMS Inbox
  • SMS 2003 Monitor SMS Executive Crash Dumps

SMS 2003 Monitor SMS Status Messages

Numerosi problemi di SMS vengono rilevati e segnalati internamente tramite il sistema di stato di SMS. Tramite i componenti di SMS vengono generati messaggi di stato relativi a condizioni che possono interessare un amministratore di SMS.

I messaggi di stato vengono trasmessi nel database di un sito SMS e, a un livello superiore nella gerarchia di siti, nel database del sito padre. È possibile monitorare il sistema di stato di SMS per ogni singolo sito, semplicemente eseguendo query sulla tabella dei messaggi di stato di SMS del database di un sito specifico.

Per il monitoraggio è stato scelto un insieme di messaggi di stato che riflettono gli eventi più critici per gli amministratori di SMS. Quando nel database viene individuato uno di questi messaggi, viene generato un avviso.

Questo script esegue le operazioni seguenti:

  • Verifica se è in esecuzione in modalità gestita senza agente. In tal caso, lo script viene chiuso senza eseguire ulteriori azioni.
  • Inizializza le variabili globali.
  • Apre e legge l'elemento RecordID dell'ultimo messaggio di stato elaborato per ogni database di sito SMS monitorato dal file SMS 2003 Monitor SMS Status Messages.VarSet.
  • Elabora i messaggi di stato individuati in ogni database di sito SMS nel computer locale.
  • Scrive l'elemento RecordID dell'ultimo messaggio di stato elaborato, per ogni database di sito SMS monitorato, nel file SMS 2003 Monitor SMS Status Messages.VarSet e chiude il file.

Tramite lo script SMS 2003 Monitor SMS Status Messages vengono generati eventi il cui ID corrisponde a quello del messaggio di stato di SMS in cui vengono segnalati. Nella tabella S.1 è descritto il formato dell'evento generato.

Tabella S.1 Formato degli eventi generati dallo script SMS 2003 Monitor SMS Status Messages

Parametro | Descrizione
EventType | Operazione riuscita, Errore, Avviso o Informazioni, in base alla gravità del messaggio di stato di SMS.
EventNumber | ID del messaggio di stato di SMS
Category | Codice sito di SMS
LoggingDomain | Dominio delle risorse del computer
LoggingComputer | Nome NetBIOS del computer
Parameter1 | Nome NetBIOS del computer
Parameter2 | Nome del modulo di SMS, ad esempio SMS Server
Parameter3 | Nome del componente di SMS
Parameter4 | ID del messaggio SMS
Parameter5 | Codice di errore Win32
Parameter6 | Codice del sito padre o del sito principale
Parameter7 | Elemento RecordID del messaggio di stato nella tabella dei messaggi di stato di SMS
Description | "Nuovo messaggio di stato SMS monitorato nel computer <NetBIOS Name> del componente <Component Name> con ID messaggio <Message ID> trovato nel database del sito <Site Code>."

Tramite lo script SMS 2003 Monitor SMS Status Messages vengono inoltre segnalati gli errori di script, contrassegnati da ID del messaggio di stato 1102:

EventType= Avviso

EventNumber= 1102

Descrizione = Errore di runtime dello script SMS 2003 Monitor SMS Status Messages in esecuzione in virtù della regola <ScriptProcessingRuleName>. Il messaggio di errore conterrà il testo "Failed to <ErrorDescription>".

Tutte le regole degli eventi di monitoraggio dei messaggi di stato di SMS 2003 iniziano con la frase "Stato SMS 2003:" e si trovano nel gruppo di regole Server database siti SMS.

  • Stato SMS 2003: Monitoraggio dei messaggi

Stato SMS 2003: Monitoraggio dei messaggi avvia lo script utilizzando la pianificazione di SMS 2003 ogni 30 minuti, sincronizzato alle 00.02 dal provider di eventi temporizzati. Le informazioni di riepilogo sono disponibili nella pagina delle proprietà Knowledge della regola.

  • Stato SMS 2003: errore script

Stato SMS 2003: errore script esegue il monitoraggio degli eventi di errore di script che potrebbero venire generati e invia avvisi relativi a tali eventi. Esiste un solo evento di errore di script, il numero 1102, che segnala tutti gli errori di script. Le informazioni sulla risoluzione dell’avviso sono disponibili nella pagina delle proprietà Knowledge della regola.

  • Stato SMS 2003: <status message name>

Stato SMS 2003: <nome messaggio stato> esegue il monitoraggio di eventi di messaggio di stato specifici e invia avvisi relativi a tali eventi. Le informazioni sulla risoluzione dell’avviso sono disponibili nella pagina delle proprietà Knowledge della regola.

Tutti gli avvisi includono una descrizione dell'evento con il formato seguente, dove $Descrizione$ indica la descrizione dell'evento:

$Computer di registrazione$ - "Nome regola". $Descrizione$

Nel file VarSet di SMS 2003 Monitor SMS Status Messages viene memorizzato in modo permanente l'elemento RecordID dell'ultimo messaggio di stato elaborato, per ogni database di sito. Il file VarSet si trova nella directory Windows\Temp. Si tratta di un file delimitato da tabulazione con il formato seguente:

Copia codice
LastRecordID_DBNameRecordID#

LastRecordID_SMS_FLA, con RecordID di 477860 indicherebbe, ad esempio, che l'ultimo elemento RecordID elaborato dal database del sito denominato SMS_FLA è stato il numero 477860.

Quando si aggiorna Management Pack da una versione precedente, nel file VarSet di SMS 2003 Monitor SMS Status Messages sono presenti i valori seguenti:

Copia codice
LastRecordID476743
LastRecordID_SMS_FLA477860

La prima riga, che non contiene un nome di database, indica la versione originale del monitoraggio dei messaggi di stato che non supporta il monitoraggio di più database. La seconda riga, che contiene un nome di database, ovvero SMS_FLA, indica che la versione corrente del monitoraggio dei messaggi di stato supporta il monitoraggio di più database.

Non verranno intraprese azioni per utilizzare la prima riga di dati in quanto, nel caso dei database di sito multipli, è difficile determinare a quale database corrisponde. La prima riga di dati non viene rimossa dal file VarSet, in quanto può essere utile per valutare le nuove modifiche e verificare che il monitoraggio dei messaggi di stato inizi con il valore di RecordID corretto dopo l'aggiornamento.

SMS 2003 Monitor Site System Summarizer

Site System Summarizer

Site System Summarizer è un thread componente del servizio SMS Executive che gestisce lo stato in tutti i sistemi del sito SMS definiti. Per impostazione predefinita, il polling dello stato corrente viene eseguito una volta all'ora, ogni ora esatta. Questo intervallo di polling è definito nel file di controllo del sito SMS. È consigliabile non modificare l'intervallo di polling. Lo stato viene memorizzato in una tabella nel database di sito SMS.

Stato DownSince del sistema del sito

Quando Site System Summarizer non è in grado di contattare un sistema del sito durante uno degli intervalli di polling, il sistema del sito viene considerato inattivo. Questa situazione può verificarsi a causa di uno dei fattori seguenti:

  • Il sistema del sito non è acceso, non è connesso alla rete o non funziona correttamente.
  • SMS Site System Summarizer non dispone di una connessione in quanto non vi sono connessioni disponibili.
  • SMS Site System Summarizer non dispone di autorizzazioni di accesso sufficienti per la connessione al sistema del sito.
  • SMS Site System Summarizer non è in grado di connettersi al sistema del sito a causa di problemi di rete.
  • Il sistema del sito è stato arrestato in modo permanente.

Disponibilità basata su Site System Summarizer

Lo stato di Site System Summarizer viene utilizzato per la creazione di report sulla disponibilità dallo script SMS 2003 Server Availability e dal report Disponibilità server SMS 2003. Per valutare la disponibilità del server SMS, viene utilizzato il valore del Registro di sistema DownSince, che consente di determinare se un server è disponibile o meno.

Limitazioni di Disponibilità basata su Site System Summarizer

In questa sezione vengono illustrate le limitazioni relative all'utilizzo dello stato di Site System Summarizer per la creazione di report sulla disponibilità da parte dello script SMS 2003 Server Availability e del report Disponibilità server SMS 2003. Per valutare la disponibilità del server SMS viene utilizzato lo stato indicato dal valore "DownSince", che consente di determinare se un server è disponibile o meno.

Il monitoraggio della disponibilità basato su Site System Summarizer presenta le limitazioni seguenti:

  • L'intervallo di polling di Site System Summarizer è di un'ora. Questo intervallo di tempo è sufficiente per l'esecuzione del polling di tutti i sistemi del sito da parte di Site System Summarizer. Per garantire un livello adeguato di prestazioni, non è possibile modificare questo intervallo. L'intervallo di timeout del generatore riepilogo è controllato dalla proprietà Startup Schedule del file di controllo del sito e non dalla proprietà Wakeup Interval. Questo significa che la modifica del valore predefinito della proprietà Wakeup Interval, pari a 60, non ha alcun effetto. Lo stesso vale per la proprietà Startup Schedule, la cui modifica non ha alcun effetto. Per impostazione predefinita, questa proprietà è impostata per l'esecuzione ogni 15 minuti e Site System Status Summarizer esegue il polling dei sistemi del sito una volta all'ora, indipendentemente dall'impostazione di Startup Schedule.
  • In base alla metodologia di controllo della disponibilità, un sito viene considerato non disponibile solo dopo il verificarsi di due eventi Generatore riepilogo sistema del sito SMS 2003: il sistema del sito potrebbe essere inattivo in un periodo di due ore. In questo modo, è possibile tenere conto di situazioni di interruzione temporanea della connettività. Questo significa che un sito viene considerato disponibile a condizione che il servizio non venga interrotto per due ore e quindi anche in caso di mancata disponibilità per brevi intervalli di tempo.
  • Molti casi di mancata disponibilità di SMS non vengono monitorati da Site System Status Summarizer. SMS viene ad esempio considerato disponibile da Site System Status Summarizer anche se i relativi servizi non sono in esecuzione o se il database di sito SMS non è disponibile, nonché quando il servizio SQL Server è interrotto.
  • I dati sulla disponibilità sono influenzati nel caso di computer che ospitano più ruoli del server SMS. Il tempo di inattività viene calcolato in base agli avvisi generati per un sistema del sito inattivo. Un singolo avviso equivale a un tempo di inattività di due ore. Tramite Site System Status Summarizer lo stato "DownSince" corrente di ogni oggetto del sito e ruolo del sistema del sito ospitato in un computer viene scritto nel database, nella tabella di Site System Status Summarizer.

Lo script Monitor Site System Status Summarizer esamina ogni ruolo del sistema del sito presente in tale tabella. Se un sistema del sito è contrassegnato come inattivo, viene generato un evento, in seguito al quale viene generato un avviso. Più ruoli possono generare più avvisi, che comportano la creazione di tempi di inattività estesi. Le percentuali di disponibilità possono pertanto risultare negative, in base all'intervallo di interesse.

Ogni ruolo del server SMS, ad eccezione del punto di distribuzione di SMS, stabilisce, per impostazione predefinita, due ruoli del server SMS, uno per il ruolo specifico e l'altro per il server del componente di SMS. Nel caso, ad esempio, di un sistema del sito che ospita sia un punto di localizzazione del server che un punto di reporting, se il server rimane non in linea per più di due ore, ovvero due intervalli di polling di Site System Status Summarizer, entrambi questi ruoli, e i relativi ruoli del server del componente di SMS, vengono contrassegnati come inattivi.

Per l'intervallo di polling per il periodo di due ore vengono tuttavia generati solo tre avvisi, uno per ogni ruolo del server e uno per il server del componente fisico che ospita i due ruoli del server. In questo modo, la disponibilità risultante sarebbe negativa in quanto verrebbero contrassegnate come non disponibili sei ore in un periodo di tempo di due ore.

  • Per impostazione predefinita, l'intervallo pianificato è di 60 minuti con uno scarto di 10 minuti dall'ora esatta, in modo che lo script SMS 2003 Monitor Site System Summarizer venga eseguito 10 minuti dopo l'inizio dell'intervallo di polling di Site System Status Summarizer di un'ora. Se il generatore riepilogo impiega più di 10 minuti per completare il ciclo, è necessario aumentare lo scarto del provider di eventi temporizzati in modo appropriato. In caso contrario, i messaggi di stato del sistema del sito più recenti andranno persi.

SMS 2003: Monitor Management Point Availability

Lo script SMS 2003 Monitor Management Point Availability supporta il report Disponibilità punto di gestione SMS 2003. La disponibilità è basata sullo stato di integrità di un punto di gestione e viene valutata utilizzando il valore dello stato di integrità seguente, disponibile nel Registro di sistema:

valore DWORD HKEY_LOCAL_MACHINE\Microsoft\SMS\MP\MPHealthState

In base a un intervallo di reporting e a una pianificazione che è possibile configurare, lo script legge, e quindi segnala, tramite un evento di Operations Manager 2007, l'intervallo di tempo durante il quale lo stato non è integro, ovvero il valore del Registro di sistema è 1 e non 0.

Questi eventi di dati sulla disponibilità vengono scritti nel database OperationsManager e nel database OperationsManagerDW. È quindi possibile eseguire un report di Operations Manager 2007 per visualizzare il tempo totale di inattività del punto di gestione durante un intervallo specificato, insieme a una percentuale di disponibilità.

Il valore del Registro di sistema MPHealthState viene gestito da MP Control Manager e viene aggiornato ogni 6 minuti.

Questo script esegue le operazioni seguenti:

  • Verifica se è in esecuzione in modalità gestita senza agente. In tal caso, lo script viene chiuso senza eseguire ulteriori azioni. Poiché lo script prevede l'utilizzo di un file VarSet locale per memorizzare in modo permanente le variabili, è necessario che l'agente di Operations Manager 2007 sia installato.
  • Inizializza le variabili globali.
  • Ottiene i parametri di input ScheduledInterval e ReportingInterval, in minuti.
  • Verifica che i parametri di input non siano vuoti, uguali a 0 o negativi. Se si verifica uno di questi casi, viene generato un evento di errore di script che indica che è stato specificato un valore non valido. Lo script verifica inoltre che il valore di ReportingInterval non sia minore di quello di ScheduledInterval. In tal caso, viene generato un evento di errore di script che indica che il valore di ReportingInterval non può essere minore di quello di ScheduledInterval. Entrambi i valori implementano un tipo Lng e non possono essere maggiori di 2147483647 (2G -1).
  • Apre il file SMS 2003 Monitor Management Point Availability.VarSet e ne copia i contenuti in una raccolta locale. Se il file non esiste, non viene generato alcun evento di errore di script. Se il file esiste ma non è possibile aprirlo, viene generato un evento di errore di script.
  • Verifica la disponibilità del punto di gestione.
    • Se la versione di SMS corrente è inferiore a 2.50.3067.0000, lo script viene chiuso senza generare errori, in quanto il valore del Registro di sistema MPHealthState non è presente. Nel file di registro delle risposte dell'agente, AgentResponses-Configuration Group Name.log, sarà inclusa l'istruzione "Monitoring Management Point health is not supported on this SMS build". Per attivare la registrazione, impostare il valore DWORD EnableActiveDebugging, nella chiave HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\OperationsManager, su 1.
    • Ottiene lo stato di integrità del punto di gestione corrente dal valore DWORD del Registro di sistema HKEY_LOCAL_MACHINE\Microsoft\SMS\MP\MPHealthState. Se non è possibile ottenere il valore, lo script viene chiuso senza generare errori, in quanto il valore non è ancora stato creato da MP Control Manager.
    • Ottiene la data e l'ora di inizio dalla raccolta VarSet. Se si tratta della prima esecuzione dello script e dell'inizio di un nuovo periodo di reporting, non vi è alcuna voce. Lo script inizializza la durata e la data di inizio, nella raccolta VarSet, prima di venire chiuso senza che venga generato alcun errore. La durata viene impostata su 0 e la data di inizio sulla data e sull'ora correnti.
    • Per l'intervallo di reporting corrente, se il valore del Registro di sistema MPHealthState è 1, lo script incrementa l'intervallo di tempo di non disponibilità nella raccolta VarSet, in base all'intervallo di pianificazione specificato.
    • Segnala, creando un evento di dati sulla disponibilità, se l'intervallo di reporting è trascorso e il punto di gestione non è stato disponibile. Lo script reimposta la durata su 0 e la data di inizio nella raccolta VarSet sull'ora locale corrente per il periodo di reporting successivo.
    • Se si verifica un errore durante il controllo della disponibilità del punto di gestione, viene generato un errore di script.

EventNumber = 1102

EventType = Avviso

Message = "The script ‘SMS 2003 Monitor Management Availability' running under processing rule <ProcessingRuleName> encountered a runtime error." CrLf "Failed to check Management Point availability”. <ErrorString>

  • Scrive i contenuti della raccolta VarSet nel file SMS 2003 Monitor Management Point Availability.VarSet locale e chiude il file. Se il file non esiste, viene creato. Se non erano state impostate variabili VarSet, non viene visualizzata alcuna voce relativa nel file. Se si verifica un errore durante la scrittura del file, viene generato un errore di script.

SMS 2003: Monitor SMS Inbox

La maggior parte delle più importanti attività sul lato server viene eseguita da SMS leggendo dai file e scrivendo nei file nelle relative cartelle di posta in arrivo. Quando le cartelle di posta in arrivo di SMS sono insolitamente piene, significa che il processo di elaborazione di SMS è rallentato. Questo problema può essere dovuto a diversi motivi, tra cui file non validi, processi interrotti, spazio su disco insufficiente o livello insolito di attività di distribuzione software. I problemi di questo tipo sono abbastanza rari, ma piuttosto gravi per i clienti con un considerevole numero di siti.

Numerosi contatori delle prestazioni per le cartelle di posta in arrivo di SMS misurano il numero di elementi aggiunti alla coda dal componente del servizio e non il numero effettivo di elementi in attesa di essere elaborati nel disco. Il contatore delle prestazioni viene aggiornato dal componente del servizio SMS dopo l'elaborazione della relativa coda corrente. Per questo motivo, i contatori delle prestazioni potrebbero venire aggiornati molto raramente, impedendo il rilevamento tempestivo di gravi backlog. Il nuovo script SMS 2003: Monitor SMS Inbox offre funzionalità di monitoraggio diretto tramite il conteggio dei file nelle cartelle di posta in arrivo di SMS critiche e invia un avviso all'amministratore tramite Operations Manager 2007 quando il numero di file in una cartella di posta in arrivo specifica supera un valore di soglia che può essere configurato dall'utente.

Tutte le regole si trovano nel gruppo di regole di elaborazione Server siti SMS – Comuni, tramite il quale queste regole vengono applicate ai siti centrale, primario e secondario. La soglia passata allo script può essere configurata tramite override.

Per garantire un livello adeguato di prestazioni, queste regole non vengono applicate ai punti di gestione o a qualsiasi altro ruolo del sistema del sito SMS.

Pianificazione e configurazione facoltativa

Per ridurre al minimo l'impatto del monitoraggio delle cartelle di posta in arrivo sulle prestazioni, le regole pertinenti vengono sincronizzate per essere eseguite una volta al giorno. Le regole vengono scaglionate a intervalli di 15 minuti, a iniziare dalle ore 01.00, in modo che venga eseguita una sola regola per volta. Tramite la prima regola vengono ad esempio contati i file presenti nella prima cartella di posta in arrivo alle ore 01.00. Tramite la regola successiva vengono contati i file presenti nella seconda cartella di posta in arrivo alle ore 01.15 e così via, fino a completare il conteggio per tutte le cartelle di posta in arrivo.

È possibile modificare questa pianificazione seguendo i passaggi utilizzati in genere per pianificare l'esecuzione degli script di regole in Operations Manager 2007. Per attivare questa funzionalità non è necessaria alcuna configurazione iniziale. Di seguito sono elencate le modifiche che è possibile apportare alla configurazione:

  • Modifica del valore di soglia predefinito per ogni cartella di posta in arrivo.
  • Modifica della pianificazione per le singole regole per le cartelle di posta in arrivo.

Queste modifiche facoltative alla configurazione possono essere apportate seguendo i passaggi utilizzati in genere per configurare le regole per gli eventi di soglia in qualsiasi Management Pack.

Avvisi e valori di soglia

Quando viene elaborata una regola di monitoraggio, viene generato un avviso ogni volta che viene raggiunto il valore soglia configurato per una regola specifica per le cartelle di posta in arrivo. Se lo script rileva un valore di soglia non valido oppure si verifica un errore durante il tentativo di monitorare il numero di file in ogni cartella di posta in arrivo, viene generato un avviso di errore di script.

Per modificare i valori di soglia delle prestazioni

  1. Nella console di amministrazione di Operations Manager 2007 fare clic su Creazione e modifica.

  2. Nel riquadro Creazione e modifica passare a Creazione e modifica/Oggetti Management Pack/Monitoraggi.

  3. Nel riquadro Monitoraggi modificare l'ambito impostandolo sul server SMS.

  4. Passare a SMS Server / Entity Health / MOM 2005 Computer Role Health, quindi espandere il ruolo del server da modificare.

    • DB - Server database
    • MP - Server del punto di gestione
    • SS - Server del sito

  5. Fare doppio clic sulla regola di monitoraggio soglia di prestazioni da modificare. Verrà visualizzata la finestra di dialogo Proprietà per i valori soglia delle prestazioni.

  6. Selezionare la scheda Configurazione.

  7. Fare clic su Modifica. Verrà visualizzata la finestra di dialogo Configurazione Xml.

  8. Nel testo XML modificare il valore di soglia appropriato.

    • Specificare il valore <ValueExpression> nidificato in <CriticalErrorExpression> per modificare la soglia degli errori critici.
    • Specificare il valore <ValueExpression> nidificato in <WarningExpression> per modificare la soglia degli avvisi.

  9. Fare clic su OK. Fare clic su OK. I valori di soglia modificati vengono distribuiti ai server.

Il valore di soglia predefinito per ogni regola di monitoraggio delle cartelle di posta in arrivo è 10.000. Impostare i valori di soglia per il parametro FileCountThreshold dello script SMS 2003: Monitor SMS Inbox appropriati per il proprio ambiente. I valori di soglia validi sono compresi tra 1 e 2147483647 (0x7FFFFFFF), inclusi. I valori di soglia non validi sono zero (0) o i numeri maggiori di 2147483647, in quanto tali numeri producono numeri negativi nell'intervallo a 32 bit.

Per una descrizione delle cartelle di posta in arrivo e di come vengono utilizzate in Systems Management Server, vedere il relativo argomento in Guida e supporto tecnico Microsoft.

Script SMS 2003 Monitor SMS Executive Crash Dumps

Questo script si trova nella cartella Scripts della console di amministrazione SMS ed è denominato SMS 2003 Monitor SMS Executive Crash Dumps. Questo script esegue le operazioni seguenti:

  • Determina se il computer di destinazione è in esecuzione in modalità senza agente. In tal caso, lo script viene chiuso senza eseguire ulteriori azioni. Poiché lo script prevede l'utilizzo di un file VarSet locale per memorizzare in modo permanente le variabili, è necessario che l'agente di Operations Manager 2007 sia installato in tutti i computer di destinazione.
  • Apre il file SMS 2003 Monitor SMS Executive Crash Dumps.VarSet locale in una raccolta e ne legge i contenuti. Se il file non esiste, non viene generato alcun evento di errore di script. Se il file esiste ma non è possibile aprirlo, viene generato un evento di errore di script, con un messaggio contenente il testo seguente:

Failed to load script variables.

  • Verifica se sono stati creati nuovi dettagli di arresto anomalo dopo l'ultimo controllo eseguito. In questo caso, viene generato un evento per segnalare i nuovi dettagli di arresto anomalo. Per generare l'evento di errore di script, lo script esegue le operazioni seguenti:
    • Ottiene la directory di installazione di SMS indicata nel Registro di sistema nella chiave Identification di SMS, nel valore "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Identification\Installation Directory". Se non è possibile ottenere il percorso, lo script genera un messaggio di evento di errore di script con il testo seguente e viene chiuso:

Impossibile leggere il valore del Registro di sistema.

  • Genera il percorso completo della directory CrashDumps accodando "\Logs\CrashDumps" alla directory di installazione di SMS recuperata.
  • Verifica se la directory CrashDumps esiste. Se la directory non esiste, lo script registra che non è stato possibile verificare l'esistenza della cartella e viene chiuso senza eseguire ulteriori azioni. Nel file di registro delle risposte dell'agente, AgentResponses-Configuration Group Name.log, sarà inclusa l'istruzione seguente:

Failed to verify existence of crash dump directory: <CrashDumpsPath>.

Per attivare la registrazione, impostare il valore DWORD EnableActiveDebugging, nella chiave HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\OperationsManager, su 1.

  • Ottiene l'ultima data di creazione della cartella di dettagli di arresto anomalo dalla raccolta VarSet.
  • Verifica se sono stati creati nuovi dettagli di arresto anomalo ed esegue azioni solo per i più recenti. Per determinare quali sono i dettagli più recenti, viene utilizzata la data di creazione della cartella salvata degli ultimi dettagli di arresto anomalo, se disponibile. Il confronto di data e ora è basato sulla data di creazione della cartella con un livello di precisione di un secondo.
  • Se sono stati creati nuovi dettagli di arresto anomalo o se è la prima volta che lo script viene eseguito, lo script registra e crea l'evento 1710, specificando il percorso e la cartella dei nuovi dettagli di arresto anomalo. Lo script salva la data di creazione della cartella dei dettagli di arresto anomalo nella raccolta VarSet. Se non sono stati creati dettagli di arresto anomalo, questa informazione viene registrata.
  • Scrive i contenuti della raccolta VarSet nel file SMS 2003 Monitor SMS Executive Crash Dumps.VarSet locale e chiude il file. Se il file non esiste, viene creato. Se non erano state impostate variabili VarSet, non viene visualizzata alcuna voce relativa nel file. Se si verifica un errore durante la scrittura del file, viene generato un messaggio di evento di errore di script con il testo seguente: Failed to save script variables.

Evento Monitoraggio dettagli di arresto anomalo SMS Executive SMS 2003

Lo script SMS 2003 Monitor SMS Executive Crash Dumps segnala, tramite l'evento 1710, che si è verificato un arresto anomalo, come descritto di seguito:

EventType = Errore

EventNumber= 1710

Category = Codice sito di SMS

Description = SMS Executive in site “XXX” has crashed. For details, see crash dump information under <Drive> \SMS\Logs\CrashDumps\NewFolder.

Evento di errore dello script Monitoraggio dettagli di arresto anomalo SMS Executive SMS 2003

Lo script “SMS 2003 Monitor SMS Executive Crash Dumps” segnala gli errori di script di runtime tramite l'evento 1102.

EventType = Avviso

EventNumber= 1102

Description = The script “SMS 2003 Monitor SMS Executive Crash Dumps” running under processing rule SMS 2003 Crash Dumps: Monitoring SMS Executive encountered a runtime error. CrLf “Failed to <Message>." ErrorString

Script SMS 2003 Server Availability

SMS è un'applicazione aziendale critica per la gestione della configurazione desktop. I clienti devono tenere traccia della disponibilità del servizio di questa applicazione. In Management Pack è disponibile uno script di Microsoft SQL Server™ di esempio per valutare la disponibilità del sistema del sito SMS in base agli avvisi generati in risposta a uno stato di inattività da SMS Site System Status Summarizer. È possibile determinare la disponibilità per un qualsiasi numero di giorni specificato. Questa metrica può essere utilizzata come supporto per i contratti di servizio stabiliti.

Limitazioni dello script SMS 2003 Server Availability

Lo script SMS 2003 Server Availability presenta le limitazioni seguenti.

I dati visualizzati sono limitati all'intervallo di pulitura database di Operations Manager 2007. Per impostazione predefinita, lo script restituisce i dati relativi agli ultimi sette giorni e agli ultimi trenta giorni. L'intervallo di pulitura del database OperationsManager è tuttavia di quattro giorni, pertanto l'esecuzione dello script con intervalli di sette e di trenta giorni restituisce gli stessi risultati. Se sono necessari report relativi a periodi di tempo più lunghi, è necessario aumentare l'intervallo di pulitura o utilizzare il report SMS 2003 Server Availability, che viene eseguito sul database OperationsManagerDW, che rappresenta l'archivio a lungo termine per i dati operativi. Per periodi di tempo più brevi, è necessario modificare gli intervalli di sette e trenta giorni nello script.

Algoritmo di script

Una volta all'ora, Site System Summarizer tenta di contattare ogni sistema del sito. Se un sistema del sito non può essere contattato, il computer viene elencato come inattivo nella tabella di Site System Status Summarizer. Per ridurre il numero di false segnalazioni di questa condizione, tramite Management Pack gli eventi vengono consolidati e viene generato un avviso solo nel caso in cui si verifichino due eventi in un periodo di due ore. Quando si esegue la stored procedure, viene calcolato il numero di avvisi che indicano che il sistema del sito potrebbe essere inattivo (“Site System is possibly down") generati durante il numero di giorni specificato, il tempo di inattività viene sottratto dal tempo di disponibilità totale e viene restituita una percentuale che indica la disponibilità per tale periodo. Se durante l'intervallo specificato in un computer non sono stati registrati avvisi “Site System is possibly down", la disponibilità calcolata corrisponde al 100%.

Non è necessario eseguire lo script con una frequenza maggiore di sette giorni, a meno che non si desideri visualizzare una tendenza giornaliera.

Per impostazione predefinita, lo script restituisce i dati relativi agli ultimi sette giorni e agli ultimi trenta giorni. Specificando un intervallo di dati più grande, è possibile ottenere una stima più accurata del tempo di attività del server. Non impostare gli intervalli su un periodo di tempo più lungo del ciclo di pulitura database di Operations Manager 2007.

Negli esempi seguenti viene illustrato in che modo aumenta la disponibilità del server con l'aumentare della lunghezza del periodo di tempo per il quale viene calcolata la media dei dati.

  • Se per un computer si verificano due eventi nel giro di due ore, viene generato un avviso. Se viene generato un avviso negli ultimi 7 giorni, i calcoli sono i seguenti:
    • Numero totale di ore in 7 giorni = 7 * 24 = 168
    • Numero totale di ore di inattività = 1 * 2 = 2
    • Numero totale di ore di attività = (168 - 2) = 166
    • Percentuale disponibilità = (166 / 168) * 100 = 98,809%
  • Se viene generato un avviso negli ultimi 30 giorni, i calcoli sono i seguenti:
    • Numero totale di ore in 30 giorni = 30 * 24 = 720
    • Numero totale di ore di inattività = 1 * 2 = 2
    • Numero totale di ore di attività = (720 - 2) = 718
    • Percentuale disponibilità = (718 / 720) * 100 = 99,72%
  • Se viene generato un avviso negli ultimi 84 giorni, i calcoli sono i seguenti:
    • Numero totale di ore in 84 giorni = 84 * 24 = 2016
    • Numero totale di ore di inattività = 1 * 2 = 2
    • Numero totale di ore di attività = (2016 - 2) = 2014
    • Percentuale disponibilità = (2014 / 2016) * 100 = 99,9%

Negli esempi seguenti viene illustrato in che modo cambia la disponibilità del server con l'aumentare del numero di avvisi registrati nello stesso periodo di tempo:

  • Se vengono generati due avvisi negli ultimi 30 giorni, i calcoli sono i seguenti:
    • Numero totale di ore in 30 giorni = 30 * 24 = 720
    • Numero totale di ore di inattività = 2 * 2 = 4
    • Numero totale di ore di attività = (720 - 4) = 716
    • Percentuale disponibilità = (716 / 720) * 100 = 99,44%
  • Se vengono generati tre avvisi negli ultimi 30 giorni, i calcoli sono i seguenti:
    • Numero totale di ore in 30 giorni = 30 * 24 = 720
    • Numero totale di ore di inattività = 3 * 2 = 6
    • Numero totale di ore di attività = (720 - 6) = 714
    • Percentuale disponibilità = (714 / 720) * 100 = 99,16%

L'intervallo di polling di Site System Status Summarizer è fissato a un'ora e non può essere modificato tramite la console di amministrazione SMS. Modificando questo intervallo non si migliora l'accuratezza dello script. È possibile modificare l'intervallo di consolidamento degli eventi, ma questa operazione non è consigliata in quanto non migliora l'accuratezza del risultato. Riducendo l'intervallo di consolidamento si ottengono infatti risultati meno affidabili, in quanto l'intervallo di consolidamento di due ore consente di ridurre i falsi risultati dovuti a interruzione temporanea della connettività.

Vedere anche

Concetti

Ulteriori risorse relative a Microsoft System Management Server 2003 Management Pack
Siti e componenti per SMS 2003 Management Pack
Gruppi di computer per SMS 2003
Gruppo di regole per SMS 2003
Provider per SMS 2003
Script per SMS 2003
Viste per Microsoft SMS 2003
Diagrammi per SMS 2003
Report per SMS 2003


Viste per Microsoft SMS 2003

In SMS 2003 Management Pack sono disponibili le viste comuni seguenti:

  • Avvisi
  • Eventi
  • Diagramma gerarchia dei siti SMS 2003
  • Vista stato
  • Vista stato attività
  • Generale
  • Prestazioni

Sono inoltre disponibili le viste seguenti, personalizzate per SMS 2003:

Diagramma gerarchia dei siti SMS 2003

  • Gerarchia di SMS 2003

Generale

  • Avvisi dal server del sito centrale SMS ricevuti nelle ultime 72 ore
  • Nuovi avvisi generati nelle ultime 72 ore

Viste relative alle prestazioni

È possibile configurare le viste in modo da mostrare i dati per determinati computer in una vista specifica. A tale scopo, è consigliabile copiare la vista che si desidera personalizzare in Area di lavoro personale, rinominarla e iniziare le operazioni di personalizzazione in base ai requisiti desiderati. È possibile ridurre la complessità del grafico selezionando il contatore specifico per i computer di interesse.

Backlog\server dei punti di gestione

  • Backlog record dei dati di individuazione nelle ultime 48 ore
  • Backlog raccolta file nelle ultime 48 ore
  • Backlog inventario hardware (HINV) nelle ultime 48 ore
  • Backlog inoltro nelle ultime 48 ore
  • Backlog inventario software (SINV) nelle ultime 48 ore
  • Backlog stato nelle ultime 48 ore

Backlog\server del sito

  • Backlog record dei dati di individuazione nelle ultime 48 ore
  • Backlog inventario hardware (HINV) nelle ultime 48 ore
  • Backlog processi utilità di pianificazione nelle ultime 48 ore
  • Backlog richieste invio utilità di pianificazione nelle ultime 48 ore
  • Backlog inventario software (SINV) nelle ultime 48 ore
  • Backlog controllo software (SWM) nelle ultime 48 ore

Generale\server dei punti di gestione

  • Disco logico nelle ultime 48 ore
  • Memoria nelle ultime 48 ore
  • Processore nelle ultime 48 ore

Generale\server del sito

  • Disco logico nelle ultime 48 ore
  • Memoria nelle ultime 48 ore
  • Processore nelle ultime 48 ore
Nota
Il provider di contatori di prestazioni per la vista LogicalDisk in the last 48 hours viene installato con Microsoft Windows Servers Base Operating System Management Pack.

Frequenze di elaborazione

  • *Tutte le frequenze di elaborazione dei messaggi in un server del punto di gestione SMS 2003 nelle ultime 24 ore
  • *Tutte le frequenze di elaborazione dei report in un server del punto di gestione SMS 2003 nelle ultime 24 ore
  • *Tutte le frequenze di elaborazione report in un server del sito SMS 2003 nelle ultime 24 ore

Frequenze di elaborazione\server dei punti di gestione

  • Record dei dati di individuazione/sec nelle ultime 24 ore
  • Tentativi di connessione al database gestione dispositivo/sec nelle ultime 24 ore
  • Record dei dati di individuazione gestione dispositivo/sec nelle ultime 24 ore
  • Richieste di conversione dell'individuazione gestione dispositivo/sec nelle ultime 24 ore
  • Posizioni punto di distribuzione gestione dispositivo/sec nelle ultime 24 ore
  • Richieste di conversione dell'inventario hardware gestione dispositivo/sec nelle ultime 24 ore
  • Inventari hardware (HINV) gestione dispositivo/sec nelle ultime 24 ore
  • Richieste ISAPI gestione dispositivo/sec nelle ultime 24 ore
  • Richieste impostazione computer gestione dispositivo/sec nelle ultime 24 ore
  • Richieste versione pacchetto gestione dispositivo/sec nelle ultime 24 ore
  • Inventari software (SINV) gestione dispositivo/sec nelle ultime 24 ore
  • Richieste corpo criterio software gestione dispositivo/sec nelle ultime 24 ore
  • Richieste ID criterio software gestione dispositivo/sec nelle ultime 24 ore
  • Stato gestione dispositivo/sec nelle ultime 24 ore
  • Totale richieste impostazione gestione dispositivo/sec nelle ultime 24 ore
  • Posizioni punto di distribuzione/sec nelle ultime 24 ore
  • Richieste di autorizzazione/sec nelle ultime 24 ore
  • Richieste di criteri/sec nelle ultime 24 ore
  • Inventari hardware (HINV)/sec nelle ultime 24 ore
  • Richieste ISAPI/sec nelle ultime 24 ore
  • Posizioni punto di gestione/sec nelle ultime 24 ore
  • Richieste assegnazione criterio/sec nelle ultime 24 ore
  • Report inoltro/sec nelle ultime 24 ore
  • Inventari software (SINV)/sec nelle ultime 24 ore
  • Stored procedure eseguite/sec nelle ultime 24 ore
  • Stato/sec nelle ultime 24 ore
  • Totale record dei dati di individuazione nelle ultime 24 ore
  • Totale record dei dati di individuazione gestione dispositivo nelle ultime 24 ore
  • Totale inventari hardware (HINV) gestione dispositivo nelle ultime 24 ore
  • Totale richieste ISAPI inviate gestione dispositivo nelle ultime 24 ore
  • Totale richieste ISAPI ricevute gestione dispositivo nelle ultime 24 ore
  • Totale inventari software (SINV) gestione dispositivo nelle ultime 24 ore
  • Totale stato gestione dispositivo nelle ultime 24 ore
  • Totale inventari hardware (HINV) nelle ultime 24 ore
  • Totale report inoltro nelle ultime 24 ore
  • Totale inventari software (SINV) nelle ultime 24 ore
  • Totale stato nelle ultime 24 ore

Frequenze di elaborazione\server di database del sito

  • Connessioni utente SQL Server nelle ultime 24 ore

Frequenze di elaborazione\server del sito

  • Record dei dati di individuazione/minuto nelle ultime 24 ore
  • Inventari hardware (HINV)/minuto nelle ultime 24 ore
  • Inventari software (SINV)/minuto nelle ultime 24 ore
  • Stato/minuto nelle ultime 24 ore
  • Controlli software (SWM)/minuto nelle ultime 24 ore
  • Totale record dei dati di individuazione nelle ultime 24 ore
  • Totale inventari hardware (HINV) nelle ultime 24 ore
  • Totale inventari software (SINV) nelle ultime 24 ore
  • Totale stato nelle ultime 24 ore
  • Totale controlli software (SWM) nelle ultime 24 ore

Vedere anche

Concetti

Ulteriori risorse relative a Microsoft System Management Server 2003 Management Pack
Siti e componenti per SMS 2003 Management Pack
Gruppi di computer per SMS 2003
Gruppo di regole per SMS 2003
Provider per SMS 2003
Script per SMS 2003
Viste per Microsoft SMS 2003
Diagrammi per SMS 2003
Report per SMS 2003


Diagrammi per SMS 2003

SMS 2003 Management Pack offre un diagramma della topologia della gerarchia SMS. I server del sito e i sistemi del sito vengono visualizzati con le relazioni corrispondenti e informazioni sensibili al contesto. I diagrammi della topologia includono dati logici quali gerarchie e siti nonché dati fisici quali server del sito e sistemi del sito. Poiché le gerarchie SMS 2003 possono essere di grandi dimensioni, è possibile limitare l'ambito della vista della gerarchia a qualsiasi gruppo di computer SMS 2003 mediante il filtro Gruppo.

Il supporto per i diagrammi della topologia in SMS 2003 Management Pack per Operations Manager 2007 prevede i requisiti seguenti:

  • SMS 2003 SP3 deve essere installato su server SMS previsti nei diagrammi
  • I diagrammi della topologia devono essere attivati
  • Ogni ruolo del sito deve essere configurato con un nome di dominio completo mediante la console di amministrazione SMS 2003

Affinché l'individuazione della topologia offra un diagramma della gerarchia SMS 2003, i computer Provider SMS devono essere gestiti, un agente deve essere installato su questi computer e l'inoltro di dati tramite agente per altri computer deve essere attivato. Inoltre, affinché vengano visualizzati connettori tra i server del sito e i sistemi del sito, i sistemi del sito devono essere stati individuati tramite un processo di individuazione SMS e devono essere membri della raccolta All Systems.

L'individuazione viene eseguita per sito dai siti primari, mentre i siti secondari vengono individuati nell'ambito dell'individuazione dei siti primari padre. I dati di individuazione vengono forniti tramite descrizione comandi e annotazioni server. È inoltre possibile esportare i diagrammi in formato Microsoft Visio®.

Annotazioni delle immagini della topologia del server SMS

Icone per i tipi di server

  • Tipo di server di database: database del sito
  • Tipo di sistema del sito: punto di gestione
  • Tipo di server: sito centrale, sito primario, sito secondario e sistema del sito

Linee di connessione

Lo stile e il colore delle linee di connessione indicano il tipo di relazione tra due computer:

  • La linea di connessione tra server del sito e server del sito è nera e continua.
  • La linea di connessione tra server del sito e sistema del sito è blu e tratteggiata.

Vedere anche

Concetti

Ulteriori risorse relative a Microsoft System Management Server 2003 Management Pack
Siti e componenti per SMS 2003 Management Pack
Gruppi di computer per SMS 2003
Gruppo di regole per SMS 2003
Provider per SMS 2003
Script per SMS 2003
Viste per Microsoft SMS 2003
Diagrammi per SMS 2003
Report per SMS 2003


Report per SMS 2003

I report descritti in questa sezione sono disponibili in SMS 2003 Management Pack. La funzionalità di report è un componente facoltativo che deve essere installato a parte. Per ulteriori informazioni sulla distribuzione del server di report, vedere la pagina Web del prodotto Operations Manager 2007 (http://go.microsoft.com/fwlink/?LinkID=83259).

Report SMS

Systems Management Server 2003 Management Pack include tre tipi di report:

  • Prestazioni
  • Configurazione
  • Disponibilità

I report vengono messi in relazione a gruppi o oggetti attraverso il selettore di oggetti. Tutti i report sono report collegati che utilizzano le funzionalità di report di Operations Manager 2007. Sono disponibili sette diversi formati esportabili per i report.

Report di disponibilità

In SMS 2003 Management Pack ci sono tre report di disponibilità che possono essere eseguiti per il gruppo di destinazione del selettore di oggetti Microsoft.SMS.2003.ServersGroup selezionando il gruppo di server SMS (Microsoft.SMS.2003.ServersGroup).

Report Disponibilità server

Il report Disponibilità server si basa sullo stato di integrità aggregato di tutte le entità su un determinato server. In questo report sono inclusi gli stati di integrità per i ruoli di monitoraggio SMS nonché gli stati di integrità di altri ruoli monitorati.

Disponibilità server sito

Il report Disponibilità server sito si basa sullo stato di integrità di un server del sito. Questo report utilizza le informazioni di Health Monitor.

Report Disponibilità punto di gestione

Il report Disponibilità punto di gestione si basa sullo stato di integrità di un punto di gestione. Questo report utilizza le informazioni di Health Monitor.

Report di configurazione

In SMS 2003 Management Pack è disponibile un solo report di configurazione, Configurazione personalizzata server SMS 2003. Si tratta di un report di configurazione personalizzato di base che contiene le proprietà di un server SMS o di un gruppo di server SMS.

Nel report sono visualizzate le proprietà SMS seguenti:

  • Versione (versione del prodotto SMS)
  • Tipo di sistema del sito (tipo di sistema del sito, tipo di server, tipo di server di database)
  • Componenti (server del sito, punto di localizzazione del server, punto di distribuzione, punto di gestione, punto di reporting, server di database, provider, server Sender, punto di accesso client)
  • Codice del sito (codice del sito SMS)
  • Tipo di server (centrale, primario, server del sito secondario)
  • Nome (nome NetBIOS)
  • Tipo di server di database (server di database del sito)

Questo report può essere eseguito per il gruppo di destinazione del selettore di oggetti Microsoft.SMS.2003.ServersGroup.

Prestazioni

I report delle prestazioni sono stati raggruppati in unità innanzitutto in base al ruolo del sito oggetto del monitoraggio e quindi in base ai contatori, ovvero contatori delle prestazioni relativi alla velocità (ad esempio per sec o per min) o contatori dei totali. Grazie a questi gruppi tutti i contatori di un report utilizzano una scala simile.

I report sono stati sviluppati in base al tipo di analisi necessaria. Sono disponibili due set di report a seconda del tipo di analisi necessaria. Un set visualizza tutti i contatori delle prestazioni di un determinato ruolo server SMS, ad esempio di un punto di gestione o un server del sito. Il secondo set visualizza tutti i contatori di un determinato oggetto di elaborazione, ad esempio l'inventario hardware, per tutti i ruoli del sito.

Report per SMS 2003 Server Performance Group

Per eseguire i report seguenti, selezionare Microsoft.SMS.2003.ServerPerformanceGroup nel gruppo di destinazione del selettore di oggetti.

Prestazioni record dati di individuazione SMS 2003

Questo report visualizza i totali e i backlog dei record dei dati di individuazione elaborati per tutti i ruoli server SMS applicabili.

Misure prestazioni SMS 2003: backlog record dati individuazione server sito | Totale record dati individuazione in coda
Misure prestazioni SMS 2003: totale record dati individuazione server sito elaborati | Totale record dati individuazione elaborati
Misure prestazioni SMS 2003: backlog record dati individuazione MP | Messaggi in coda
Misure prestazioni SMS 2003: MP DDR Mgr (totale report) | Totale report
Misure prestazioni SMS 2003: totale record dati individuazione DMP elaborati | Totale report individuazione generati

Prestazioni velocità record dati individuazione SMS 2003

Questo report visualizza le frequenze di elaborazione dei record dei dati di individuazione per tutti i ruoli server SMS applicabili.

Misure prestazioni SMS 2003: velocità elaborazione record dati elaborazione server sito | Record dati elaborazione elaborati al minuto
Misure prestazioni SMS 2003: MP DDR Mgr (totale report/sec) | Totale report/sec
Misure prestazioni SMS 2003: frequenze di elaborazione record dati individuazione DMP | Report individuazione generati/sec

Prestazioni HINV SMS 2003

Questo report visualizza i totali e i backlog dell'inventario hardware (HINV) elaborati per tutti i ruoli server SMS applicabili.

Misure prestazioni SMS 2003: backlog HINV server sito | Totale MIF in coda
Misure prestazioni SMS 2003: totale HINV server sito elaborati | Totale MIF elaborati
Misure prestazioni SMS 2003: backlog HINV MP | Messaggi in coda
Misure prestazioni SMS 2003: MP HINV Mgr (totale report) | Totale report
Misure prestazioni SMS 2003: totale HINV DMP elaborati | Totale report inventario hardware generati

Prestazioni velocità HINV SMS 2003

Questo report visualizza le frequenze di elaborazione dell'inventario hardware (HINV) per tutti i ruoli server SMS applicabili.

Misure prestazioni SMS 2003: velocità elaborazione HINV server sito | MIF elaborati/minuto
Misure prestazioni SMS 2003: MP HINV Mgr (Totale report/sec) | Totale report/sec
Misure prestazioni SMS 2003: MP HINV Retry Mgr (totale report/sec) | Totale report/sec
Misure prestazioni SMS 2003: velocità elaborazione HINV DMP | Report inventario hardware generati / sec

Prestazioni SINV SMS 2003

Questo report visualizza i totali e i backlog dell'inventario software (SINV) elaborati per tutti i ruoli server SMS applicabili.

Misure prestazioni SMS 2003: backlog server sito SINV | Totale SINV in coda
Misure prestazioni SMS 2003: totale SINV server sito elaborati | Totale SINV elaborati
Misure prestazioni SMS 2003: backlog MP FileCollection | Messaggi in coda
Misure prestazioni SMS 2003: backlog MP SINV | Messaggi in coda
Misure prestazioni SMS 2003: MP Sinv Mgr (totale report) | Totale report
Misure prestazioni SMS 2003: totale SINV DMP elaborati | Totale report inventario software generati

Prestazioni velocità SINV SMS 2003

Questo report visualizza le frequenze di elaborazione dell'inventario software (SINV) per tutti i ruoli server SMS applicabili.

Misure prestazioni SMS 2003: velocità elaborazione SINV server sito | SINV elaborati/minuto
Misure prestazioni SMS 2003: MP Sinv Mgr (totale report/sec) | Totale report/sec
Misure prestazioni SMS 2003: MP Sinv ColFile Mgr (totale report/sec) | Totale report/sec
Misure prestazioni SMS 2003: velocità elaborazione SINV DMP | Report inventario software generati /sec

Prestazioni risorse sistema server SMS 2003

Questo report visualizza l'utilizzo delle risorse di sistema da parte dei ruoli server SMS.

Misure prestazioni SMS 2003: memoria - %byte impegnati in uso | Byte impegnati in uso
Misure prestazioni SMS 2003: file di paging - % utilizzo | % utilizzo
Misure prestazioni SMS 2003: processore - % tempo processore (_ totale) | % tempo processore
Misure prestazioni SMS 2003: processo - % tempo processore (smsexec) | % tempo processore
Misure prestazioni SMS 2003: processo - % tempo processore (ccmexec) | % tempo processore
Misure prestazioni SMS 2003: sistema - tempo attività sistema | Tempo attività sistema

Prestazioni SWM SMS 2003

Questo report visualizza i totali e i backlog del controllo software (SWM) elaborati per tutti i ruoli server SMS applicabili.

Misure prestazioni SMS 2003: backlog SWM server sito | Totale file utilizzo SWM in coda
Misure prestazioni SMS 2003: totale SWM server sito elaborati | Totale record utilizzo SWM elaborati
Misure prestazioni SMS 2003: backlog MP Relay Mgr | Messaggi in coda
Misure prestazioni SMS 2003: MP Relay Mgr (totale report) | Totale report

Prestazioni velocità SWM SMS 2003

Questo report visualizza le frequenze di elaborazione del controllo software (SWM) per tutti i ruoli server SMS applicabili.

Misure prestazioni SMS 2003: velocità elaborazione SWM server sito | Record utilizzo SWM elaborati / minuto
Misure prestazioni SMS 2003: MP Relay Mgr (totale report/sec) | Totale report/sec

Prestazioni messaggi di stato SMS 2003

Questo report visualizza i totali e i backlog dei messaggi di stato SMS elaborati per tutti i ruoli server SMS applicabili.

Misure prestazioni SMS 2003: totale messaggi di stato server sito elaborati | Ricevuti
Misure prestazioni SMS 2003: backlog stato MP | Messaggi in coda
Misure prestazioni SMS 2003: MP Status Mgr (totale eventi) | Totale eventi
Misure prestazioni SMS 2003: totale messaggi stato DMP elaborati | Totale messaggi di stato generati

Prestazioni velocità messaggi di stato SMS 2003

Questo report visualizza le frequenze di elaborazione dei messaggi di stato SMS per tutti i ruoli server SMS applicabili.

Misure prestazioni SMS 2003: velocità elaborazione stato server sito | Elaborati/sec
Misure prestazioni SMS 2003: MP Status Mgr (totale eventi/sec) | Totale eventi/sec
Misure prestazioni SMS 2003: velocità elaborazione stato DMP | Messaggi di stato generati/sec

Prestazioni servizi supporto ruoli server SMS 2003

Questo report visualizza le prestazioni dei servizi che supportano i ruoli server SMS.

Misure prestazioni SMS 2003: servizio Web (richieste estensioni ISAPI /sec) | Richieste estensioni ISAPI / sec
Misure prestazioni SMS 2003: connessioni SQL SMS | Connessioni utenti

Report per SMS 2003 Management Point Server

Per eseguire i report seguenti, selezionare Microsoft Management Point Servers nel gruppo di destinazione del selettore di oggetti.

Prestazioni 2003 Device Management Point

Questo report visualizza i totali elaborati per il ruolo server SMS Device Management Point.

Misure prestazioni SMS 2003: totale record dati individuazione DMP elaborati | Totale report individuazione generati
Misure prestazioni SMS 2003: totale HINV DMP elaborati | Totale report inventario hardware generati
Misure prestazioni SMS 2003: totale SINV DMP elaborati | Totale report inventario software generati
Misure prestazioni SMS 2003: totale messaggi stato DMP elaborati | Totale messaggi di stato generati
Misure prestazioni SMS 2003: totale richieste ISAPI DMP inviate | Totale messaggi inviati
Misure prestazioni SMS 2003: totale richieste ISAPI DMP ricevute | Totale messaggi ricevuti

Prestazioni velocità SMS 2003 Device Management Point

Questo report visualizza le frequenze di elaborazione per il ruolo server SMS Device Management Point.

Misure prestazioni SMS 2003: velocità richieste impostazione DMP | Richieste impostazione DMP / sec
Misure prestazioni SMS 2003: velocità richieste impostazione computer DMP | Richieste impostazione computer/sec
Misure prestazioni SMS 2003: velocità richieste ID criterio software DMP | Richieste ID criterio software/sec
Misure prestazioni SMS 2003: velocità richieste corpo criterio software DMP | Richieste criterio corpo software/sec
Misure prestazioni SMS 2003: velocità richieste versione pacchetto DMP | Richieste versione pacchetto/sec
Misure prestazioni SMS 2003: velocità richieste conversione individuazione DMP | Richieste conversione individuazione/sec
Misure prestazioni SMS 2003: velocità richieste conversione inventario hardware DMP | Richieste conversione inventario hardware/sec
Misure prestazioni SMS 2003: velocità tentativi connessione database DMP | Tentativi connessione database/sec
Misure prestazioni SMS 2003: frequenze di elaborazione record dati individuazione DMP | Report individuazione generati/sec
Misure prestazioni SMS 2003: velocità elaborazione HINV DMP | Report inventario hardware generati / sec
Misure prestazioni SMS 2003: velocità richieste posizione DP DMP | Richieste posizione generate/sec
Misure prestazioni SMS 2003: velocità elaborazione messaggi ISAPI DMP | Messaggi invaiti/sec
Misure prestazioni SMS 2003: velocità elaborazione SINV DMP | Report inventario software generati /sec
Misure prestazioni SMS 2003: velocità elaborazione stato DMP | Messaggi di stato generati/sec

Prestazioni SMS 2003 Management Point

Questo report visualizza i totali e i backlog elaborati per il ruolo server SMS Management Point.

Misure prestazioni SMS 2003: backlog record dati individuazione MP | Messaggi in coda
Misure prestazioni SMS 2003: MP DDR Mgr (totale report) | Totale report
Misure prestazioni SMS 2003: backlog HINV MP | Messaggi in coda
Misure prestazioni SMS 2003: MP HINV Mgr (totale report) | Totale report
Misure prestazioni SMS 2003: backlog MP FileCollection | Messaggi in coda
Misure prestazioni SMS 2003: backlog MP SINV | Messaggi in coda
Misure prestazioni SMS 2003: MP SINV Mgr (totale report) | Totale report
Misure prestazioni SMS 2003: backlog MP Relay Mgr | Messaggi in coda
Misure prestazioni SMS 2003: MP Relay Mgr (totale report) | Totale report
Misure prestazioni SMS 2003: backlog stato MP | Messaggi in coda
Misure prestazioni SMS 2003: MP Status Mgr (totale eventi) | Totale eventi

Prestazioni velocità SMS 2003 Management Point

Questo report visualizza le frequenze di elaborazione per il ruolo server SMS Management Point.

Misure prestazioni SMS 2003: MP Location Mgr (richieste MP/sec) | Richieste MP/sec
Misure prestazioni SMS 2003: MP Location Mgr (richieste DP/sec) | Richieste DP/sec
Misure prestazioni SMS 2003: MP Get Policy (richieste/sec) | Richieste/sec
Misure prestazioni SMS 2003: MP Get Auth (richieste/sec) | Richieste/sec
Misure prestazioni SMS 2003: MP Policy Mgr (richieste PA/sec) | Richieste PA/sec
Misure prestazioni SMS 2003: MP DAL (SP eseguiti/sec) | SP eseguiti/sec
Misure prestazioni SMS 2003: MP HINV Mgr (totale report/sec) | Totale report/sec
Misure prestazioni SMS 2003: MP HINV Retry Mgr (totale report/sec) | Totale report/sec
Misure prestazioni SMS 2003: MP SINV Mgr (totale report/sec) | Totale report/sec
Misure prestazioni SMS 2003: MP SINV ColFile Mgr (totale report/sec) | Totale report/sec
Misure prestazioni SMS 2003: MP Relay Mgr (totale report/sec) | Totale report/sec
Misure prestazioni SMS 2003: MP Status Mgr (totale eventi/sec) | Totale eventi/sec

Vedere anche

Concetti

Ulteriori risorse relative a Microsoft System Management Server 2003 Management Pack
Siti e componenti per SMS 2003 Management Pack
Gruppi di computer per SMS 2003
Gruppo di regole per SMS 2003
Provider per SMS 2003
Script per SMS 2003
Viste per Microsoft SMS 2003
Diagrammi per SMS 2003
Report per SMS 2003